[Hummingbird] Browsing Cache

Hi guys,
when i try to clear the cache of my site i am getting the following error message. Can you please check?
Browser Caching is not working properly:

- Your server may not have the "expires" module enabled (mod_expires for Apache, ngx_http_headers_module for NGINX)
- Another plugin may be interfering with the configuration

  • Dimitris
    • Support Star

    Hey ALEXANDROS

    Please go to HummingBird -> Caching -> Browser Caching and check the code when you select "Manual Setu"

    that's already inside the .htaccess file of this installation.

    If not, please share your .htaccess file here with us (simply rename it to .txt, remove any sensitive data and attach it here in your next reply).

    If HummingBird's Browser Caching rules are already in place, please do contact your hosting provider to double check that server does have the "expires" module enabled (mod_expires for Apache, ngx_http_headers_module for NGINX). Also ask them which server type they use exactly, Apache, NGINX or both of them.

    Warm regards,
    Dimitris

    • ALEXANDROS
      • WPMU DEV Initiate

      Now on the Page Cache section i am getting the following error message. I checked it and my "wp-config.php" file includes the line "define('WP_CACHE', true);"

      "Hummingbird could not locate the WP_CACHE constant in wp-config.php file for WordPress. Please make sure the following line is added to the file:
      define('WP_CACHE', true);"

  • Nastia
    • Support Rock Star

    Hello ALEXANDROS

    Hope you're doing well!

    Regarding Page Caching issue, the define('WP_CACHE', true); line was added at the bootom of the wp-config.php file.

    Any lines that you add at the wp-config.php file should go above "/* That's all, stop editing! Happy blogging. */" line. I've changed the WP_CACHE line position and place it above, which has fixed issue with the Page Cache.

    I've checked the .htaccess rules and these are added right but they won't show that browser cache is enabled. I've checked your site with Browser Cache online check tool: https://www.giftofspeed.com/cache-checker/

    And the browser cache for all files from your site is enabled. So looks like it is enabled on the server level, and our plugin uses loopbacks to verify if caching working and server might not allow it.

    Let us know if you have any further questions!

    Cheers,
    Nastia

  • ALEXANDROS
    • WPMU DEV Initiate

    Hi Nastia!
    Yes i see that the page caching is working.
    On then browser tab, i keep getting the following message, no matter if i change the caching duration. Can you please check it out?

    "4 of your cache types don’t meet the recommended expiry period of 8+ days. Configure browser caching here."

  • Nastia
    • Support Rock Star

    Hello ALEXANDROS

    I trust all is well!

    Browser cache is enabled on your site. Based on this online browser cache check tool browser cache is enabled for CSS files for 30 days, JS files 16 days, SVG files 14 days, images 30 days.

    Hummingbird plugin uses loopbacks to verify if caching enabled and some server does not allow it. So Hummingbird can't detect if browser cache is enabled.

    Let us know if you have any further questions.

    Kind regards,
    Nastia

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.