HUMMINGBIRD CACHE AND GZIP MAY NOT WORK

Hi,

I have my own dedicated server on which I run this website. I have installed Hummingbird and enabled caching and gzip compression. I have followed the instructions given by this plugin to enable cache and gzip in Apache and NGINX but at the end I am receiving the same result on my end for browser caching http://screencast.com/t/8cVX4FZeeQ and gzip compression http://screencast.com/t/ds79ws0EH18x
If I check gzip compression for my website here http://screencast.com/t/v8usMJ8GASK or here http://screencast.com/t/ILiEeCygBDL8 it says that gzip is enabled on my site.

Does anyone knows or maybe guesses where and what am I doing wrong?

Thanks,
Vladimir

  • Adam Czajczyk

    Hello Vladimir,

    I hope you're well today and thank you for your question!

    It seems that your server is running a "LiteSpeed" web server and support for it is not yet fully implemented in Hummingbird. Our developers are aware of this so I'm sure on of the future releases will include "LiteSpeed" as well.

    However, as inappropriate as it sounds, I wouldn't worry much about the error that you're receiving. You mentioned that you applied the Apache instructions to your site so you should be good to go. LiteSpeed was built with Apache compatibility in mind and my tests also shows that both .gzip compression and browser caching are enabled on your site. This would mean that the setup actually worked but the plugin is not able to detect it due to what I said above about LiteSpeed support in Hummingbird.

    The bottom line is: I think you could safely ignore the error message for now and hopefully one of upcoming Hummingbird's version will bring full support for LiteSpeed meaning the error will go away in cases like this one.

    I hope that makes sense :slight_smile:

    Best regards,
    Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.