[Hummingbird] Cache break my site

I optimize my website with hummingbird everything is fine.

But one or two days after when I visit again the website certain page doesn't have their css loaded.

So the layout is broke, I refresh my chrome cache but nothing happened.

The only way to resolve this is to clear the cache of hummingbird.

After that the page looks as usual, perfect and the website .

Have you ever experienced this problem ?

Thanks for your feedback and help.

  • Adam Czajczyk
    • Support Gorilla

    Hello Julien Ferla

    I hope you’re well today and thank you for your question!

    Once the cache is generated and is fine, it shouldn’t be breaking “over time”. If anything, it should be “broken” right away. It is, however, possible that it actually is broken “right away” – it might take some time to create cache so once you enable Page Caching, some parts of you site might be cached pretty much instantly and some (that get less traffic) over time. One way or another, I’d expect that something more is involved in the case.

    Could you tell me please:

    – are those some specific pages on site or rather “random” ones?

    – does it always happen on a (more or less) “regular schedule” or it’s more intermittent?

    – do you have Asset Optimization enabled in Hummingbird?

    – is there any server-side caching currently enabled (you might need to consult that with your host to make sure)?

    I’d also like to take a closer look at your site’s setup so would you please enable support access to it for me? To do so, please go to the “WPMU DEV -> Support” page in your site’s back-end and click on “Grant support access” button there, then let me know here one it’s enabled.

    Looking forward to hear from you,


  • Julien Ferla
    • Site Builder, Child of Zeus

    Hi Adam,

    Thanks for your feedback.

    I juste launch my new website yesterday, so as you will understand I checked every page, everything before the launch and everypage look good.

    but today when I check again my website I find a page without the css,.. but yesterday this page look ok.

    after that I cleared the cache and all the page are ok now.

    So to answer your question I don’t have enough view from this new website as I launch it yesterday…

    Asset Optimization is on

    no server side caching

    I grant access so you can take a look

    Let me know

  • Predrag Dubajic
    • Support

    Hi Julien,

    I had a look at your site, and the caching showed that all the pages were cached but I didn’t see any issues with the mentioned page, or any other pages on your site for that matter.

    I also cleared the cache, then visited it again to get it cached and checked it afterward but still didn’t see any issues.

    I did enable caching logging on your site so if the issue happens again we can check if there will be any info of the cause there.

    Also, if you do see the issue again can you check if there are any console errors on the page?

    You can start browser console in Chrome by pressing Command + Option + J on Mac or Control + Shift + J on Windows.

    If there are any errors shown you can right click on empty space in the console and save it to your PC.

    You can change the extension to TXT and attach it here so we can check the errors that you’re getting.

    Best regards,


  • Adam Czajczyk
    • Support Gorilla

    Hello Julien Ferla

    Thank for your response!

    I think we got a bit of a confusion here :slight_smile: You have assigned one of your sites (with support access already enabled) to this ticket but the screenshot that you attached to your last post refers to a different site. We’ve been checking the site assigned to this ticket.

    The one that’s shown on the screenshot – I see it registered on your account but there’s no support access granted to it. However, by the looks of the mixed content errors, I suspect that the site is not fully configured for HTTPS:

    Could you please login to that site, go to the “Settings -> General” page and make sure that both “WordPress Address (URL)” and “Site Address (URL)” options are starting with “https://” prefix instead of “http://”? If they are not, please update it and then go to the “Hummingbird -> Dashboard” page and use “Clear cache” button there to clear all the caches on site, then let it re-generate and check the site again.

    If that doesn’t help, I’d need to take a closer look at the site so in such case, please enable support access to the site in question and let me know here.

    Best regards,


  • Julien Ferla
    • Site Builder, Child of Zeus


    it’s not a confusion,… I just have other website encounter the same problem, with the same configuration.

    Sa as you suggest I’ve looked at the console and find that the problem maybe comes from this mixed content despite the correct https configuration in the settings.

    The http content is called from the wmpudev cdn if I am correct

    >> http://hb.wpmucdn.com/

    and after emptied the cache everything work perfectly.

    This website is online since one year and sometimes I’ve noticed this behaviour too… and always the same error and css unloaded.

    so yes it’s not the website I contact you for, but that’s the same behaviour and error,… I think that’s a interested fact to know…

  • Adam Czajczyk
    • Support Gorilla

    Hi Julien Ferla

    Thanks for explanation, that makes perfect sense now :slight_smile:

    As for WPMU DEV CDN. Yes, these resources’ URLs were causing mixed content issue. However, when Hummingbird puts assets on the WPMU DEV CDN it follows the site configuration – at least it should, unless there’s something else interfering: that might either be the issue of that aforementioned configuration or there’s some other plugin or setting that’s “breaking” HTTPS detection. Or rather – was when those resources were initially uploaded to our cloud.

    It’s good to know that clearing up the cache fixed it, though the question is now – did it fix that indeed or… didn’t the cache get fully re-build yet. I believe you’re referring to the Hummingbird cache, right? It might be good to keep an eye on this to try to “catch” that exact moment when the issue happens again (if it happens) and try to find some “pattern/rule” that it follows as there must be some reason for this.

    Best regards,


  • Julien Ferla
    • Site Builder, Child of Zeus

    it happen again,… and as previous the problem come from mixed content load from the WPMU DEV CDN.

    I clear the hummingbird cache and it resolve the problem,… but How long my website was broke ?

    I can't visit all of my website every hour to see if they work !!

    That's very annoying I pay for the WPMU DEV Service and a main feature as hummingbird, cache, CDN optimisation service break my website.

    As you seen the main config url of the website is in https,…

  • Predrag Dubajic
    • Support

    Hi Julien,

    I’m sorry to hear this happened again to you, could you provide us with FTP or cPanel access so we can investigate this further and check what might be going?

    Note: Don’t leave your login details in this ticket.

    Instead, you can send us your details using our contact form https://premium.wpmudev.org/contact/#i-have-a-different-question and the template below:

    NOTE: Don’t change selected topic in the dropdown, just leave it at “I have a different question”.

    Subject: “Attn: Predrag Dubajic

    – Site login URL

    – WordPress admin username

    – WordPress admin password

    – FTP credentials (host/username/password)

    – cPanel credentials (host/username/password)

    – Folder path to site in question

    – Link back to this thread for reference

    – Any other relevant urls/info

    Best regards,


  • Anton Vanyukov
    • Developer

    Hi Julien Ferla,

    We have released an update to the plugin, which includes several fixes and improvements to the page caching module. Could you please update it to the latest version and check if that resolves your issue?

    Once you update, I’ll also apply an update to your logging module, so we can track the issue, just in case it happens again.

    Best regards,


Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.