Hummingbird cache gets cleared after a few minutes

If I run a speed test hummingbird tells me that I should enable the cache. I have done this already.

If I take a look at the dashboard of the page caching then it shows 0 cache files. If I browse the website in an incognito tab then I see the number of cache files increase to 1/2/3 but a few seconds later it goes back to 0 again.

  • Kasia Swiderska
    • Support nomad

    Hello Tim ,

    I’m sorry to hear about this issue with our plugin.

    We have checked and it looks like option “Clear full cache when post/page is updated” is causing this – I have disabled it temporarily and I’m checking with developers what could be the reason for this unusual behaviour.

    We will keep you posted.

    kind regards,

    Kasia

  • Patrick Freitas
    • Staff

    Hi Tim

    Hope you are doing well.

    I made some new tests on Hummingbird, and couldn’t find the cause, I’ve checked the cronjobs on your site and they seem to be running fine.

    I escalated this to our Second Line Support, note, the second line support deal with a more complex situation, a delay on response is expected.

    Thank you for understanding,

    Best Regards

    Patrick Freitas

  • Tho Bui
    • Staff

    Hey there Tim,

    Regarding your issue, if you enabled “Clear full cache when post/page is updated” when having an update from a post/page included the post from non-public post type (ex: an updated from Form/Poll/Quiz of Forminator Pro or an update from Custom Fields of Advanced Custom Fields) HUMMINGBIRD (HMB) will trigger clear full cache function. So I think HMB working fine as the config.

    Default if you disable this option, HMB still deletes cache the post/page had an update. And I checked in Forminator plugin and see this plugin also support to delete the cache of post/page contains the Forminator shortcode if have an update in form. So I suggest you disable this option. You can manually delete all the cache via admin if you want.

    Best Regards,

    Tho Bui

  • Tim
    • New Recruit

    Hi Tho Bui ,

    I’m not completely sure I understand what you mean. I think what you are saying is: each page which is changed in wp-admin (can be a page, a post, a settings page, updating a custom field, etc) will trigger the cache to be cleared.

    If that is what you are saying then yes this is correctly functioning but this was not my issue.

    The issue I have is that if you are done with editting the cache is still getting emptied after some seconds. So not only if you are doing an edit but also if you are not editting anything at all.

    Thanks,

    Tim

  • Tho Bui
    • Staff

    Hello Tim,

    Sorry for not clarifying there, edit/insert new non-public post can trigger from other plugins on cronjobs, ex: when Defender scanning, HMB running minify, …

    In that case, if you want to disabled full clear cache trigger from the non-public post I have prepared a custom snippet which you can use as a guide here :

    https://gist.github.com/wpmudev-sls/d2833d70d661907754000d9f0572b4b8

    You can download a zip, unzip it and upload file hmbp-disable-auto-clear-cache-in-not-public-postype.php to your wp-content/mu-plugins folder. If that folder doesn’t exist you can simply create it.

    If you are not familiar with mu-plugins you can read about them here:

    https://premium.wpmudev.org/manuals/wpmu-manual-2/using-mu-plugins/

    or you can paste it in your child theme’s functions.php file.

    Kind regards,

    Tho Bui

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.