[Hummingbird] Cache problem

When trying to use the plugin, I get this: "Your server may not have the "expires" module enabled (mod_expires for Apache, ngx_http_headers_module for NGINX)"

I contacted the web hosting company and they can't help me.

Furthermore, concerning the Smush plugin, "Smush" doesn't show up on the media page. Please view: https://drive.google.com/file/d/1UTJKPejt1dHpeRLOpla3DERSOAFzIPjK/view?usp=sharing

Thanks,
JL

  • Patrick Freitas
    • Staff

    Hi James Leesley

    Sorry to hear that you are having this issue.

    Wouldn't you mind, please, grant the support access, and we can take a closer look for you?

    1. Log in to the WordPress Admin Panel for your site (go to the Network Admin dashboard if on Multisite), and then navigate to the “Support” page from the WPMU DEV menu item (WPMU DEV > Support).

    2. Click the “Grant Support Access” button in the Support Access panel.

    References on https://premium.wpmudev.org/docs/getting-started/getting-support/#chapter-5

    Let us know when you had granted the support access.
    Best Regards,
    Patrick Freitas

  • Patrick Freitas
    • Staff

    Hi James Leesley

    Hope you are doing well.

    Yes, please, you can follow the information.

    Note: Don't leave your login details in this ticket.

    Instead, you can send us your details using our contact form https://premium.wpmudev.org/contact/#i-have-a-different-question:

    Subject: "Attn: Patrick Freitas"

    - Site login URL:

    - WordPress admin username:
    - WordPress admin password:

    - FTP/SFTP credentials

    Host:
    Username:
    Password:
    Port:

    - cPanel credentials

    Host:
    Username:
    Password:

    - Folder path to the site in question:

    - Link back to this thread for reference

    - Any other relevant URLs/info:

    Please, reply to the ticket once you have sent the information.
    Best Regards
    Patrick Freitas

  • James Leesley
    • New Recruit

    Hello,
    Getting you FTP/SFTP and cPanel is something I don't know how to do, so I went ahead and GRANTED YOU support access, skipping the "New User" option I mentioned before.
    --
    Here are the two problems:
    1. I'm receiving this error when I"m setting up the Hummingbird Pro: "Your server may not have the "expires" module enabled (mod_expires for Apache, ngx_http_headers_module for NGINX)"
    2. I'm not able to "Smush" individual images because that option isn't available on the right-hand side - contrary to the sample image given on how to use the plugin.

    Thanks,
    JL

  • Kasia Swiderska
    • Support nomad

    Hello James,

    I'm sorry for the delay on our side. I'm afraid support access is no longer working, can you enable it again?

    I contacted the web hosting company and they can't help me.

    What do they mean by that? They can't install those modules on your site or they refuse to tell you if they are installed? This is important because without those modules it will not work.

    Furthermore, concerning the Smush plugin, "Smush" doesn't show up on the media page. Please view: https://drive.google.com/file/d/1UTJKPejt1dHpeRLOpla3DERSOAFzIPjK/view?usp=sharing

    Smush Plugin has now separate menu Icon, it's no longer under Media:

    kind regards,
    Kasia

  • James Leesley
    • New Recruit

    Hello,
    Support Access was off because it's been more than five days since I enabled it for the last person. It's back on now.
    As for your other question, the person I talked to said we were going so deep that they couldn't help me: "Beyond my scope," is what the person said. I don't have anything else to tell you, it's beyond my scope as well.

  • James Leesley
    • New Recruit

    Okay, thank you.
    Concerning the other issue with Smush Pro (not being able to compress, or "Smush," individual images, one at a time), can you tell me what the instructions are for that? Note that this button "Smush individual images via your Media Library," (see attached image) yes, takes you to the Media Library, but "Smush" isn't available there.

    Thanks,
    JL

  • Ashik
    • Staff

    Hello James,

    Thank you for the reply. Hope you're doing well today!

    While you're on Media Library and Automatic Smush is disabled for your site or few images that's not Smushed yet, you'll see a button beside each image to Smush image manually if you're viewing Media Library in list mode. Screenshot attached

    In another case if your Media Library is in grid mode, you'll have to click on each image and you'll see a button to Smush manually. Screenshot attached

    As your site has enabled Automatic Smush, you do not need to worry about manual Smush process. Upon upload all images will Smush automatically.

    Now the question is why still Smush showing X number attachment that needs smushing!. The case is few images uploaded before installation of Smush or Automatic Smush wasn't enable that time.

    So, for invidual Smushing you can follow the above instruction or do bulk Smush. It's easy and time saving method.

    Feel free to reply here if you've any more questions or concerns about this topic. Have a great day ahead.

    Regards,
    Ashik

  • James Leesley
    • New Recruit

    I've done everything you said, but none of it is working.

    Please test your instructions on our site before sending them to me to make sure they're correct, it would drastically help our situation here instead of us continuing to go back and forth. Thanks.
    --
    Note: the image in the picture that's attached to this message is 1.2 MB.

  • Ashik
    • Staff

    Hi James Leesley,

    Thank you for your reply and sorry for the misunderstanding.

    I had tested Smush on your site and as I said Smush working on your site automatically based on settings. That's why upon click on the image what I've uploaded, it's not showing BUTTON for manual Smush instead it's showing stats as already It's Smushed. See the screenshot

    Now I think the worried question is for you "why I can't see any button?". Well, only a few images are left from thousand plus images to Smushed. So, you've to move page by page to see the image which is not Smushed yet. Like I found few one in the last page of the library. Go Dashboard > Media > Library click on pagination link to land on the last page of the library. See screenshot

    You'll found few images there to Smush manually. Follow the same process for the other images as well.

    Let me clarify one more thing. Please see your library as the list view. So, no need to click image to see Smush button. Otherwise, you'll have to click on each image to see the Button. That actually time-consuming work. See screenshot, how you can view the library as List or Grid view.

    Hope these clarifications will be enough to break your confusion. Feel free reply here if you've any more questions or concerns. Have a great day.

    Regards,
    Ashik

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.