[Hummingbird] Can't Configure Browser Cacheing

When I got to browser cacheing page there's no button at the bottom to save so it says it's not active. Please help. Thanks!

  • Kris Tomczyk

    Hi John

    Hope you are doing good today.

    By default in "Browser Caching" section there should be an "Activate" button.

    From what you wrote this looks like a plugin conflict. Would you please run a conflict test? Please deactivate all plugins except Hummingbird and check if the problem gone. If so, then enable all plugins one by one and find which one is having conflict. If there is no positive result, switch to default WordPress theme like 2017 and see if it works.

    If plugin conflict will not give any positive results I will need your site and FTP access to take a closer look on this issue. Please send it through our secure contact form here https://premium.wpmudev.org/contact/#i-have-a-different-question and make sure that subject is "I have a different question" and:
    - Mark to my attention: ATTN: Krzysztof Tomczyk
    - Site access (url / username / password)
    - FTP credentials (host / username / password)
    - Link back to this thread

    Please confirm here in thread that you have sent that message.

    Kind Regards,
    Kris

  • James Morris

    Hello John

    Since you don't currently have Support Access enabled, I was not able to check your site to see what you've already done, but after running Google PageSpeed, GTMetrix and Pingdom Tools on your site, it appears that you're not leveraging the full potential of Hummingbird. Most (if not all) of the issues I'm seeing with performance could be handled by Hummingbird.

    Would you please take a look at the documentation we've put together for Hummingbird? This guide will walk you through setting up the plugin and configuring its options for optimal performance. https://premium.wpmudev.org/docs/wpmu-dev-plugins/hummingbird/

    Once you have worked through this guide, if you still have any issues, please feel free to ping us back here and we'll be more than happy to assist you! :slight_smile:

    Best regards,

    James Morris

  • Katya Tsihotska

    Hi John

    Hope you're having a great day!

    I've reviewed your site and in order to improve your site performance, I would recommend you to do the following:

    1. I've noticed that in the Assets Optimization you're using only the Compress option. I would recommend you also enabling Combine, Inline, Footer and Defer options for as many files as possible. But please, do this carefully for each file one by one. Here you can find more detailed information on how these options work (scroll down to the Advanced Mode section):
    https://premium.wpmudev.org/docs/wpmu-dev-plugins/hummingbird/#chapter-4

    2. I've noticed that you're using PHP version 5.6.30, it's ok, this version isn't outdated, but you will find much better performance if you can upgrade to PHP 7.x.

    3. In order to improve your server response time, you can also try using Object Caching. Here you can find a list of the object caching plugins:
    https://codex.wordpress.org/Class_Reference/WP_Object_Cache#Persistent_Cache_Plugins

    If you will use a plugin with multiple cache types, make sure you're using only the object caching, to avoid conflicts with the Hummingbird.

    Hope this helps.

    Kind regards,
    Katya

  • John

    I can't run a performance test. Also, when I try to compress files in asset optimization I click compress and then click publish at the bottom. Nothing happens. Getting a poor score on google insights page speed tool. please help get the site loading faster. I have a lot of sites using hummingbird and most of them are loading slowly. Not sure what I'm doing wrong. I've read all the documentation and can't get it loading fast. please help thank you!

  • James Morris

    Hello John

    Due to liability and time constraint issues, I'm afraid we cannot go through your site and fully configure Hummingbird for you. We provide documentation and when something doesn't work as designed, we'll troubleshoot it and fix it. But it's the responsibility of the user to configure the plugin to suit the needs of their individual site.

    That being said, your issues with not being able to run a performance test or use compression are things we can and would be happy to look into further for you.

    In order to help you better with those issues, would you please grant me access to your site?

    You can learn how to grant WPMU DEV Support Access at the following link:

    https://premium.wpmudev.org/docs/getting-started/getting-support/#chapter-5

    Please reply back here once you've enabled access so I will be notified.

    Best regards,

    James Morris

  • John

    I just enabled support access for 2 sites that are having this issue, in case you want to check both. One is hosted with godaddy and the other with hostgator.

    https://resource4signs.com/wp-admin/

    https://americansignstudio.com/wp-admin/

    Also, I've noticed a glitch on pretty much all the sites with WPMU installed that the WPMU DEV option in wordpress menu disappears and you have to deactivate and then reactivate the plugin to get it to show. Do you know what might be causing that?

    Thank you!

  • Adam Czajczyk

    Hello John,

    Thank you for enabling support access.

    I checked the amerciansignstucio.com site so let me give you some suggestions below.

    1. Please login to your hostgator cPanel and look for an option where you can switch PHP version for that domain; You should be able to switch to some 7.x version so start with that please.

    2. Second step is to look in hostgator panel if you do have any caching options there; if they are there and are disabled, disable them - Hummingbird already provides the cache and server-side cache may interfere.

    3. You got 30 plugins active there and some of them are quite heavy; the theme is not particularly lightweight too. However, while your server allows up to 256M of RAM memory to be used for PHP scripts, your WordPress is still limited to only 40M which is way to little for this particular setup. To fix that, enter your Hostgator panel again and use "File Manager" tool there:

    - edit the "wp-config.php" file of this site
    - above the "/* That's all, stop editing */" line add this exact line:

    define( 'WP_MEMORY_LIMIT', '256M');

    4. Go to the "Hummingbird -> Caching -> Page Caching" page and disable caching (temporarily, you'll enable it back later)

    5. Go to the "Divi -> Theme Options -> General" page and disable both "minify" options there (for CSS and for JS)

    6. Go to the "Hummingbird -> Dashboard" page and and click on "Clear cache" button there
    7. Go to the "Hummingbird -> Asset Optimization" page and use "Re-check files" button there to re-set asset optimization

    8. Once that process is complete open your site once or twice (front-end) in another browser, then give it some time; keep visiting the "Hummingbird -> Asset Optimization" page to see when the process is complete; after that:

    a) for the first file on the list enable "combine" option
    b) publish changes
    c) refresh front end in the other browser and see if the site is working fine; if yes, repeat a, b, and c, for the next file on the list; if not, disable "combine" option for that file and proceed the same procedure with the next one. Repeat that until you reach the end of the list

    d) repeat a, b and c the same way for "Move to footer" option, then for "force load after the page loaded" (where availble).

    This is a time consuming and quite daunting procedure but will allow you to "squeeze out" every "bit" of asset optimization that's possible.

    9. Once that's set up, go back to "Hummingbird -> Caching -> Page Caching" page and enable Page Caching there again.

    After that, browse the site for a while in other browser as a logged out user to let the cache re-build itself.

    Finally, see if you can then run performance report and also check your scores in PageSpeed Insights.

    If that all together still doesn't solve the performance report issue or doesn't speed up the site or both - let me know here.

    Kind regards,
    Adam

  • Adam Czajczyk

    Hi John

    Is this the same server or a different one? Let me know, please.

    Apart from this, I checked the site and I think you should start with two basic changes:

    1. Increase WP memory limit as it's still running on a default 40M which is quite a small amount for a site with some "heavy" plugins. That can be done by adding following line to the "wp-config.php" file right above the "/* That's all, stop editing */" line:

    define('WP_MEMORY_LIMIT', '256M');

    2. Upgrade PHP. Currently the site's powered by 5.4.45 which is way outdated already. I'd consider a 5.6.x version an absolute minimum but better switch to 7.x (7.1.x or 7.2.x), you should be able to do it via cPanel.

    Not only it would positively affect site performance, stability and security, but it's also very likely related to the issues with Hummingbird (it can also affect other plugins).

    Give it a go, please, and let's see if helps.

    Best regards,
    Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.