Hummingbird CDN mixed content

Getting a mixed content error on some sites in my network. The issue appears to be specific to a site, as other sub-sites with the same plugins work fine.

Tried SSL Insecure Content Fixer but didn't solve. When I reset Asset Optimization from Hummingbird the error goes away and back again.

  • Adam Czajczyk

    Hello mynym

    I hope you're well today and thank you for your question!

    I have accessed and checked your site. The sub-site in question is supposed to run over SSL connection (and is somehow redirected to it) but it's not configured properly for SSL. Any WP site that is set for SSL should use "https://" protocol prefix in URL.

    Please go to the "Network Admin -> Sites" and click on "Edit" for the site in question. In a "Settings" tab you will notice that both "Siteurl" and "Home" options values are starting with non-SSL "http://" prefix while in this case they should be set to start with "https://".

    Adjusting the prefix, then clearing caches and resetting Asset Optimization should solve the issue. Since there are mapped domains, it might also be better to first remove them, then make the change, then follow with clearing caches and re-setting AO and only after that mapping them again.

    Give it a try please and let me know if it worked for you.

    Kind regards,
    Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.