Hummingbird changes font

Recently I have the problem, that Hummingbird keeps changing the font on my website. Whenever I run a performance test or clear the cache, the font is changed to some default font. To make it load the correct font, I just have to deactivate Humminbird, and it looks the way it should. However, after activating Hummingbird again and clearing cache or running the performance test, it's gone wrong again.
After having made experiments on my test site, the problems consists even after deactivating all plugins apart from the one crucial to the theme.
I run the theme Grand photography by Theme goods.
Peter M.

  • James Morris
    • WordPress Enthusiast

    Hello Peter M.,

    I hope you are well today.

    Usually, when you see this symptom, it's because your font defines are not playing well with other CSS on your site. With Hummingbird, you can easily exclude individual assets to help determine where the problem is.

    Go into WP Admin -> Hummingbird -> Minification.
    Click the Advanced Options menu
    Deselect the fonts from being included in Minification
    Save and clear Cache

    Please check by doing hard refresh in your browser (CMD+SHIFT+R on Mac or CTRL+F5 on Win) and let us know if it's loading properly for you then.

    Best regards,

    James Morris

  • Peter M.
    • New Recruit

    Hello James

    Thank you for your thorough reply.

    I have done quite a bit of experimenting now, but not really nailed it yet.

    I can get the font right, but then the dash-icons for the slider goes wrong, and no matter what I exclude from minification, font-icons seems to break.

    What annoys, even more, is that I can set it right, and make the font correct in the front end browser, but it seems to switch back by it selves??? After a few alterations in Hummingbird it's suddenly wrong again, and when I look into the minification dashboard, it's switched back. Then I exclude it from minification and it looks fine again.

    Somehow I sense that I have three options:
    -Use Hummingbird and accept that my webpage looks strange
    -Not use Hummingbird and accept that my webpage is slow.
    -Spend numerous hours trying to locate which item to exclude from minification, and maybe get it right.

    I guess I'll go with the last option a little more and see where it ends.

    Best regards
    Peter M.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.