Hummingbird constantly recheck Assests

Assets Optimization keep rechecking randomly almost every time I'm making a change. And that clears all my previously edited settings.

See image.

Tried deactivating all other plugins, and re-installing Hummingbird but still having the same issue.

  • Predrag Dubajic

    Hey JRC,

    Hope you're doing well.

    I was doing some testing on my installation and only way I could replicate this is when hitting enter while working on the Asset Optimization page, for example when I type in search term and then hit enter.

    I went through your chat with Huberson but I'm afraid that I'm not completely sure that I understand when exactly does it happen for you, so can you tell me if you're experiencing the same thing, meaning that it happens when you hit enter, or does this happen to you when you do some other actions as well?

    Best regards,
    Predrag

  • JRC

    Hi James:

    After trying to customize the asset optimization multiple times, the plugin keep rechecking files and resets all previous settings, after the following actions:

    - When I search for specific plugins.
    - When I'm excluding plugin files, before I have a chance to hit save or anything - it rechecks.

    I'm sure it occurs when there are similar scenarios but those are the ones I can confirm as of right now. I have tried but turning the CDN off and on again but didn't make a difference.

    Thanks,
    Christina

  • Adam Czajczyk

    Hello JRC

    - When I'm excluding plugin files, before I have a chance to hit save or anything - it rechecks.

    Does this mean that all you have to do to trigger the "re-check" is to just toggle the "Exclude" switch on or off, without even publishing changes or doing anything else?

    I'm asking just to make sure because I just tried that on my test setup but with no luck and I also have accessed your site where I switched a couple of "Exclude" switches in Asset Optimization on and off (they're all set as they were, no changes after all) and it didn't run "re-check" either.

    So, if you can confirm that toggling such switch is all that you need to do to run "re-check", could you tell me please what browser and OS are you working with (including versions) and if you tried with different browsers? Also, if you do have some/any extensions active in browser, did you try to disable them, clear browser cache, and check again?

    Let me know please as this may help me test it further.

    Best regards,
    Adam

  • Adam Czajczyk

    Hello Christina,

    Thank you for your reply.

    I have accessed the site again and I must say I still couldn't replicate this. I was also testing it using Win 10 Pro, now on latest Chrome, but to know luck.

    However, I have also accessed the server and did some more research there. One thing that I have changed so far is that I have raised your WordPress memory limit, which was set to 40M (that's default value for a single WP install) - that's way to less for that kind of setup. I have set it to 256M so please clear your caches again and see if the issue still happens.

    If it does, please try something more (I'm asking you to do this because after making certain changes I would be logged out of support access and wouldn't be able test it, neither I would be able to fix it in case anything went wrong):

    1. Access files on your server and go to /wp-content/mu-plugins folder, then remove temporarily the only .php file that's there (just make a copy to be able to bring it back)

    2. then get back to the wp-config.php file of your site and open it for editing; fine this piece of code:

    define('AUTH_KEY',         'put your unique phrase here');
    define('SECURE_AUTH_KEY',  'put your unique phrase here');
    define('LOGGED_IN_KEY',    'put your unique phrase here');
    define('NONCE_KEY',        'put your unique phrase here');
    define('AUTH_SALT',        'put your unique phrase here');
    define('SECURE_AUTH_SALT', 'put your unique phrase here');
    define('LOGGED_IN_SALT',   'put your unique phrase here');
    define('NONCE_SALT',       'put your unique phrase here');

    then visit this URL

    https://api.wordpress.org/secret-key/1.1/salt/

    and you'll be given a replacement code so us it to replace the one that's currently in "wp-config.php" file.

    Once you save the file you should be logged out from the site. Clear the caches in browser again, login back to the site and see if the issue is still happening.

    Finally, if it's still happening, please install the "Twenty Seventeen" theme on your site and temporarily switch from your current theme to that one. Again - clear caches and test.

    Let me know about results and we'll then see what (if anything would be necessary) to do next.

    Kind regards,
    Adam

  • JRC

    Hi Adam:

    Thanks for your follow-up and providing multiple resolutions in case one didn't work. I had interesting results....

    1. I thought the increased memory would do the trick - it did not trigger rechecking asset as I was making small changes and saving...However the issue did reoccur after searching and hitting enter so I continued to the next step.

    2. Updating PHP file with replacement code from https://api.wordpress.org/secret-key/1.1/salt/ -- It completely deactivated my asset optimization and will not turn back on. weird!!

    3. Tried step 3 to see if the Hummingbird Pro would work - checking files goes straight to 99-100% then never activate.

    Very weird results...thoughts??

    Thanks,
    Christina
    JRC

  • Adam Czajczyk

    Hello JRC

    Thanks for running tests and sharing results.

    I think these results mean that we are actually dealing with two issues here.

    I think that in general raising memory limit for WordPress helped. The issue with Asset Optimization check being restarted after "searching and hitting enter" - that I was able to finally replicate and since both me and Predrag could do this, I'm reporting this as a bug to our developers. The search is working in "ajax mode" so the list should be dynamically updated while you're typing in into the search box but still - hitting enter shouldn't re-trigger file check.

    The second issue would be that that even though raising memory initially seemed to help, then resetting salts (the change in wp-config.php file) caused it to reset and doesn't allow to start it back, the same as switching the theme. I tried to replicate that on my end but to no success - upon each attempt it was still set the same way as it was.

    To sum it up:

    1) I think that "hitting enter re-triggers AO" is a bug (more of an UI bug tho)
    2) The fact that after updating salts and switching theme AO cannot be set up again seems to be specific to the site.

    The bug (#1) I have already reported to our developers so they could look into it and release a fix. The second issue: I tried to find a reason for that but I admit I'm a bit stuck so I have also reached out to our developers so they would look into it and gave us a helping hand on it.

    Please keep track of this ticket for further information and I hope we'll be able to solve that riddle soon :slight_smile:

    Best regards,
    Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.