Hummingbird - Contact Form doesnt work ?

Hi,
I worked out that when i have hummingbird installed my contact form on my contact page doesnt work it is giving me an error that the user hasn't filled in all the required fields when you have. This error doesn't happen when i deactivate hummingbird and submit the form so i am pretty sure its that.
Can you advice on what i can do to fix this with hummingbird activated?
I am using Elegant Themes: Divi ...

I have just deactivated Hummingbird whilst waiting for support response, as i have had people complain about the form.

  • Adam Czajczyk

    Hello Belinda,

    I hope you're well today and thank you for your question!

    I'm guessing that there was a Minification feature enabled in Hummingbird, is that correct?

    This is the feature that's usually causing such issues. It doesn't mean that it's a bug so let me explain please :slight_smile:

    The "Minification" feature means that CSS and JS files (coming from the WordPress core, theme itself and other plugings) are first - kind of - compressed and then combined so the tool makes for example 3 files out of 10 that were originally there.

    This improves performance and security but unfortunately can cause some issues as well and there's no way to predict that or "automatically" detect. That's why there's a warning on top of "Minification" screen of Hummingbird :slight_smile:

    That for "theory" :slight_smile: As for fixing it: I'd start with enabling Hummingbird again and going to "Minification" screen. Then disable minification by toggling the switch on the very top of it (on the left of "Discard changes" gray button) and then enabling it again.

    It will re-check files and set minification which probably will break the contact form again. However, you would then use "Filter" drop-down box to find out all files belonging to the plugin that the form is create with (or the "Divi" theme if the form is native to Divi) and then toggle off switches for all JS files listed: do not toggle off switches in "Include" column but only in "Minify" and "Combine". After you save those changes please clear your site's cache (if you're using any caching plugins such as e.g. W3 Total Cache or similar) and test the form.

    Let me know please if that worked for you.

    Best regards,
    Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.