Hummingbird crashes CDN

After installing Hummingbird and letting it minify my website I have encountered a peculiar error.

I´m using the Ionicons (http://ionicons.com/) for my icon font. But with hummingbird the link loading this does not work. Originally it should be a
<link rel='stylesheet' id='ionicons-css' href='//code.ionicframework.com/ionicons/2.0.1/css/ionicons.min.css?ver=1.0.0' type='text/css' media='all' /> when viewing the site source.

But with hummingbird activated I get nothing of the sort. Instead I get a minified hummingbird.css file consisting of the ionicons. And I can´t seem to find a setting to remove this from getting minified and crushed into a single style.css hummingbird edition.

What to do? Thank you for your time.

  • Nastia
    • Support Rock Star

    Hello Henrik , I hope you are doing well today!

    The Hummingbird plugin combining and minifying all CSS files in hummingbird.css file. You can deactivate minification for a specific file from Hummingbird > Minification, locate the ionicons-css file, and deactivate Minify and Combine options

    Please see the screenshot:

    If you require any further assistance, please grant access from WPMU DEV > Support so I can have a closer look?

    Please see the detailed instructions on the link below:
    https://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Let me know when you do!

    Cheers,
    Nastia

  • Henrik
    • WPMU DEV Initiate

    Yeah, from my knowledge if I turn minification off completely then everything works. But one does want to use all the tools of the trade that you guys get my money for so I´ll grant you access to try and find out if some settings will allow me to have minification enabled and still not make me have these issues.

    edit - Access granted.

  • Nastia
    • Support Rock Star

    Hello Henrik , I trust all is well!

    Thank you for granting access. I deactivated minification for files that were causing this issue. Right now the Hummingbird minification is activated and font from ionicons is working well on your site.

    Let me know if you have any further questions.

    Cheers,
    Nastia

  • Henrik
    • WPMU DEV Initiate

    how long does it take for the minification to work trough everything? Since now my file singular.js is not loaded instead.

    So before I start writing posts about how it isn´t working with this file instead I might as well ask how long the minification takes? Since now I have the file excluded from the minification but it still isn´t anywhere near to be seen.

    If you check out a single post like http://deculture.se/varfor-jag-inte-kommer-kopa-final-fantasy-15/ you will see below the post content I have a "previous post Yakk Deculture" with a gray background? That should be a image background. And as it is now it won´t load the script that collects the information that is needed.

    Same with the Genesis-share js. Below each post there is a "share" section where people can share the posts by clicking on links. But now the html is outputted but not the buttons.

    So one step is finished yes. But there are more to be done it seems.

  • Nastia
    • Support Rock Star

    Hello Henrik ,

    My apologies for the delay here. Usually the minification needs like 15 minutes, till the cache clears out.

    It looks like the minification or combines options needs to be deactivated for the Genesis-share.js.

    Please note that not all files can be minified and work properly at the same time. This depends on how the were built in the first place.

    The support access has expired, would you please re-grant it again, so I could have a closer look?

    Please advise,

    Cheers,
    Nastia

  • Henrik
    • WPMU DEV Initiate

    Yues. Access granted again. 15min for the humingbird cache to clear out. Then I know. Thank you for this info.

    edit - No worries about this taking time. I have a feeling as a company your always busy so I´m grateful for you taking your time with me.

  • Nastia
    • Support Rock Star

    Hello Henrik , I hope all is well!

    I visited your site, played a with minification, it was not easy to find the correct file, it was actually the theme's style.css file that was affecting article's background image. It should be visible now.

    Would you please have a look at your site now to confirm that everything is showing as it should?

    Let me know how it goes!

    Kind regards,
    Nastia

  • Henrik
    • WPMU DEV Initiate

    I´ve gone trough the sites now and for me now it seems to be working all together. So thank you for all your help.

    Funny though that the style.css would be affecting that since when I checked the single.js wasn´t loaded at all. Hm. But now it´s working and all I good.

    Thanks for the help once again!

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.