Hummingbird doesn't recognize images already smushed

Hey! I uploaded all my images to my media library and smush went to work on them. Next, I created a slider using revolution slider and smushed images from my library. Then I ran Hummingbird and it tells me to get a better score, smush those images! Where am I going wrong?

  • Luís

    Hi Chris ,

    Hope you're doing well today!

    I checked your site and the issue is related to the full-size images. When you upload an image to the Media library, WordPress crops and resizes every image uploaded (to create the thumbnails). By default, Smush only compresses these cropped and resized images, not your original full-size images.

    You can easily overcome this issue, enabling the option "Include my original full-size images " in WP Smush (network admin panel -> Settings -> WP Smush):

    I hope this information has been helpful. If I can help you in this or other questions, please let me know!

    Cheers, Luís

  • Chris

    Hi Luís,
    Thanks for that. So I have set that setting as suggested and Smush says all of my images are optimized but Hummingbird does not and still lists those images in revolution slider as being the culprits. Yet, in Media library when I click on Smush stats, it shows my full size images smushed as well. Do you think it is just a bug in Hummingbird, not updating the smush changes?

  • Luís

    Hi Chris ,

    Hope you're doing well today!

    Firstly, sorry for the extreme delay in the reply and all the problems it may have caused.

    I checked your website and confirmed the changes were made, but, Hummingbird still gives the recommendation about those images, even they were already optimized.

    I already pinged the developer to get his valuable feedback on this, I will update this topic once I got a reply.

    Cheers, Luís

  • James Morris

    Hello Chris,

    Thank you for re-enabling Support Staff Login. After taking a deeper look at your site, I'm seeing that the options were not fully configured at the network level, which was limiting what you could do on your subsite.

    See screenshots:
    https://goo.gl/ZqSRXO
    https://goo.gl/bE7d21

    If you go to Network Admin -> Settings -> WP Smush you will be able to configure these settings so that you can further optimize your images.

    I hope this clarifies a bit.

    Best regards,

    James Morris

  • Chris

    James,
    I think maybe I have not been clear.
    I don't really want any lossy compression on this site, it is an art and photography site so we are trying to limit the loss of quality of the images. All images in the site are smushed to some degree. This can be confirmed by looking through the media library smush stats. The issue is that the images in the slider (even though they have been smushed according to smush notifications in the media library) are being reported by Hummingbird as not being smushed. And Hummingbird is giving me a score of 2 on images... so in fact this most likely is not a Smush issue, rather a Hummingbird issues, or compatibility issue between hummingbird and Smush.
    Make better sense?

  • James Morris

    Hello Chris,

    The reason Hummingbird is reporting those images as being not optimized is because they could be optimized a little more using the Super Smush option in Smush. Hummingbird checks optimization much like Google PageSpeed. If there's still some optimization that can be performed, Hummingbird will report it.

    To test this definitively, I downloaded one of the images that Hummingbird said was not optimized. I verified that it had been optimized in Smush on your site. I then uploaded it to my dev site and tested it. Google PageSpeed said it could be optimized more, just the same as Hummingbird did. Same percentage and all. I then changed Smush to do maximum compression and retested. Google PageSpeed no longer reported the image needed optimized.

    Since the images Hummingbird is reported images for your slider, I checked the code generated by the slider. The source images are actually smaller dimension than what the slider is scaling too. So, the slider is making the images bigger than they are. So, scaling is not really an issue.

    So, in your situation, since you would rather not super smush your images or do PNG->JPG compression, yes Hummingbird is going to report that some of your images could still use being optimized. This is not a bug. This is the intended way the plugin works.

    Also, I ran your site through Google PageSpeed, GTMetrix and Pingdom Tools. Your site's speed is very good. So, what small speed gains you would get from further optimizing these images are negligible.

    For more information, please see the following articles:
    https://developers.google.com/speed/docs/insights/OptimizeImages
    https://premium.wpmudev.org/blog/100-score-google-pagespeed-insights-not-happening/

    I hope this clarifies a bit.

    Best regards,

    James Morris

  • Chris

    Hi James,

    Thanks for taking the time for the great explanation, and the research that you went through to provide the answer.

    This of course leads to yet another question!

    Hummingbird is saying that I have to do further compression on specific images, but not all images. Why are some images listed and not all images?

    And as a side question, is there any way to pick and choose which images get super smushed and which don't?

    I have other sites with many images on them that have been smushed and resized etc., but not (lossy settings) super smushed or PNG to JPG converted and am getting a much higher score, i.e.: 65 instead of 2.

    I know, I am lucky to have such a speedy server and I am happy with the performance, but of course, I am always looking for ways to optimize more!

  • James Morris

    Hummingbird is saying that I have to do further compression on specific images, but not all images. Why are some images listed and not all images?

    This is most likely due to the images already being optimized. For example, since you are compressing automatically on upload, the thumbnail sizes are going to be fairly well optimized. You might be able to gain a few % points by Super Smushing those, but perhaps not.

    If you are linking to your full-size images using the optimized thumbnails, this could explain why you are not seeing more images that need optimized. I believe this is because Hummingbird checks for optimization of the images actually rendered on page and not linked images.

    And as a side question, is there any way to pick and choose which images get super smushed and which don't?

    Unfortunately, no. This is not possible at this point in time. But it would be a nice feature. I can move this thread to the Features & Feedback forum if you would like.

    I have other sites with many images on them that have been smushed and resized etc., but not (lossy settings) super smushed or PNG to JPG converted and am getting a much higher score, i.e.: 65 instead of 2.

    Are you using Gzip compression on one site but not the other, by chance? Truthfully, I'd have to look at both sites side-by-side to see why there's such a disparity in the scores.

    Best regards,

    James Morris

  • Chris

    Hey James,

    Thanks for that. I am still kind of scratching my head a bit. If I delete the shortcode that displays the slider, my score on images goes to 100. If I add the slider back in, my score drops to 2. That's quite the spread! Interestingly, the images in the slider are not really as important as the images on the rest of the site, especially as we add the photos being selected by the client for her portfolio. Obviously she wants her portfolio to be as good quality as possible.

    Yes! Of course, this would be a nice feature to be able to select which images are smushed and which can be supersmushed etc. and I would think many others might think so as well.

    I do have gzip enabled. My server is probably way overkill, so speed is not really an issue for me. I'm just an iron junkie who got a killer box for the cost of a good vps, and hopefully someday I will use the other 95% of its resources!