Hummingbird: Error saving compressed file

Hello,

When I try using Hummingbird's minification functionality, it gives me the following error below each JS/CSS file (in the File Details column): "Error: Error saving compressed file"

Also, when I initially installed Hummingbird, it could not create the "wp-hummingbird-cache" directory in /uploads/, so I had to create it manually.

Finally, I could only install Hummingbird (and other WPMU plugins) via the native WP plugin installer, not via WPMU Dashboard (where it produced an error about correct permissions).

Two things that I guess could have caused all this:
1. Folder/file permissions (most likely): I have folders set to 755, files to 644. Which permissions would Hummingbird require - and for which folders?

2. FTP/file access: we have disabled the direct FS_METHOD in wp-config, plus FILE_EDIT is disabled as well. So for instance, we have to include the FTP password when installing plugins (and we do not have FTP_USER/PASS/HOST declared in wp-config)

Thank you,
Konstantin

    Rupok

    Hi Konstantin,

    Actually there are two facts associated. "File/Directory Permission" and "File/Directory Ownership". Suppose you are using apache in your server. When you install LAMP natively in Ubuntu, the default user for apache is "www-data". So when "www-data" is the owner of your files/directories inside your web root, you won't need to provide FTP Credentials while installing plugins. If you use VestaCP control panel for your server, then default user for your files should be "admin".

    Now you said "we have to include the FTP password when installing plugins", that clearly indicates, files/directories in your server don't have proper apache/nginx owner. In a perfect setup where files/directories have proper owner, you won't need to enter FTP Credentials for installing themes/plugins.

    At this point, I totally think, as your directories don't have proper owner, nothing can write new files/directories on your server without FTP Credentials and as a result, Hummingbird and Dashboard plugin can't create/modify files and directories as they don't ask for FTP Credentials from you.

    So, currently you have two options:
    1. You declare your FTP Credentials in your wp-config.php file.
    2. I can login to your server with SSH, try to find the proper user for your file, and change ownership of those files with "chown" command. You will get more idea about this command here: https://www.techonthenet.com/linux/commands/chown.php

    If you prefer the second option, can you send me message with SSH access credentials through our secure contact form here: https://premium.wpmudev.org/contact/ so I can try to fix this for you?

    Subject: "Attn: Rupok"
    - SSH root Username
    - SSH root Password
    - SSH Login IP
    - Link back to this thread for reference
    - Any other relevant URLs

    Select "I have a different question" for your topic. This and the subject line ensure that it gets assigned to me.

    Please send me those credentials and I believe, I can fix this issue for good. I'm looking forward to hear from you and resolve this issue as soon as possible.

    Have a nice day. Cheers!
    Rupok

    Konstantin

    Hello Rupok,

    Thank you for getting back to me!

    I have tried option 1 - did not work. It did solve the WPMU Dashboard plugin installation issue, BUT Hummingbird still outputs those errors for every file.

    Here is what I have in wp-config at the moment (FTP values removed for security reasons):

    /** define( 'FS_METHOD', 'direct' );
    define( 'FS_CHMOD_DIR', 0775 );
    define( 'FS_CHMOD_FILE', 0664 ); */
    define( 'FTP_USER', 'user' );
    define( 'FTP_PASS', 'pass' );
    define( 'FTP_HOST', 'host.com' );
    define( 'FS_CHMOD_DIR', ( 0755 & ~ umask() ) );
    define( 'FS_CHMOD_FILE', ( 0644 & ~ umask() ) );
    define( 'DISALLOW_FILE_MODS', false );
    define( 'DISALLOW_FILE_EDIT', TRUE );

    Could any of these settings interfere with what Hummingbird needs to do?
    And is there anything else I can try?

    Re Option 2: unfortunately this is our client's server, so we do not have full access.

    Thank you,
    Konstantin