[Hummingbird] GZip Compression issue

Hi there, my hosting provider assures me I have GZip compression enabled on the server (https://checkgzipcompression.com/?url=http%3A%2F%2Finthesoil.on.ca), but I'm getting an error from Hummingbird:

Gzip is not working properly:

- Your server may not have the "deflate" module enabled (mod_deflate for Apache, ngx_http_gzip_module for NGINX).
- Contact your host. If deflate is enabled, ask why all .htaccess or nginx.conf compression rules are not being applied.
If re-checking and restarting does not resolve, please check with your host or open a support ticket with us.

Can you help? I've re-checked it several times.


  • Huberson
    • Recruit

    Hello Joe
    This might happen if you have some proxy enabled on your server, though can't be sure without checking.

    Try adding the following to your php.ini:
    zlib.output_compression = On
    Or this in .htaccess:

    <ifModule mod_deflate.c>
    <FilesMatch "\.(css|js|x?html?|php)$">
    SetOutputFilter DEFLATE

    If above don't help, please enable support access to the site and we'll have a closer look.


  • Joe
    • New Recruit

    OK, I've enabled support access. I added that code to the .htaccess file. I don't have access to the php.ini file though, I don't think. I'll need to look.

    Also, what just started happening now is my Assets Optimization tool no longer works. It isn't scanning files, and won't let me turn it on.

    Please let me know what you can do!

  • Kasia Swiderska
    • Support nomad

    Hello Joe,

    I don't have access to the php.ini file though, I don't think. I'll need to look.

    You can create this file on your server if its not there - some hosting providers allow for that.

    Also, please revoke and grant access again to your site - we had some updates for that on our side and revoking is necessary to have it open again.

    kind regards,

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.