[Hummingbird] GZip compression not workign on site

Two questions:
1. GZip show in Plugin admin area not working. mod_deflate is enabled http://ammrg.com/test_deflate.html and .htaccess has all appropriate entries.
2. On top of home page this message comes up intermittently, how do I remove it ? is cached by the Hummingbird Performance plugin v1.8.0.1 - https://wordpress.org/plugins/hummingbird-performance/. -->

  • James Morris

    Hello Yuriy Petushkov,

    I hope you are well today.

    Could you please try adding the following directives to your .htaccess file?

    <IfModule mod_deflate.c>
    AddOutputFilterByType DEFLATE text/plain
    AddOutputFilterByType DEFLATE text/html
    AddOutputFilterByType DEFLATE text/xml
    AddOutputFilterByType DEFLATE text/css
    AddOutputFilterByType DEFLATE application/xml
    AddOutputFilterByType DEFLATE application/xhtml+xml
    AddOutputFilterByType DEFLATE application/rss+xml
    AddOutputFilterByType DEFLATE application/javascript
    AddOutputFilterByType DEFLATE application/x-javascript
    AddOutputFilter DEFLATE .shtml
    </IfModule>

    Also, in order to help you better with your issue, would you please grant me access to your site?

    You can learn how to grant WPMU DEV Support Access at the following link:

    https://premium.wpmudev.org/docs/getting-started/getting-support/#chapter-5

    Please reply back here once you've enabled access so I will be notified.

    Best regards,

    James Morris

  • Kris Tomczyk

    Hi Yuriy Petushkov,

    Hope you are doing good today.

    I tested your site on those pages and it seems that GZIP is not fully enabled on your server.
    https://varvy.com/tools/gzip/
    http://www.gidnetwork.com/tools/gzip-test.php
    http://www.gziptest.com/

    I also see that JavaScript and CSS compression works fine. There is only problem with HTML MIME type.

    It's possible the "mod_deflate" module are not configured to handle with all required MIME types, so, can you please contact your host provider to double check if it supports "text/HTML".

    As for "message showing up on top of my website" - we are aware of this above issue.
    It was already fixed by our developers. Please update your plugin in plugins section and this message should be gone.

    Kind Regards,
    Kris

  • Yuriy Petushkov

    Thank you , yes it start working after this modifications been made to Apache configuration file: AddOutputFilterByType DEFLATE text/plain
    AddOutputFilterByType DEFLATE text/html
    AddOutputFilterByType DEFLATE text/xml
    AddOutputFilterByType DEFLATE text/css
    AddOutputFilterByType DEFLATE application/xml
    AddOutputFilterByType DEFLATE application/xhtml+xml
    AddOutputFilterByType DEFLATE application/rss+xml
    AddOutputFilterByType DEFLATE application/javascript
    AddOutputFilterByType DEFLATE application/x-javascript

    And this to to httpd conf file ###############################################################
    <IfModule mod_mime.c>
    AddType application/x-javascript .js
    AddType text/css .css
    </IfModule>
    <IfModule mod_deflate.c>
    AddOutputFilterByType DEFLATE text/css application/x-javascript text/x-component text/html text/plain text/xml application/javascript
    <IfModule mod_setenvif.c>
    BrowserMatch ^Mozilla/4 gzip-only-text/html
    BrowserMatch ^Mozilla/4.0[678] no-gzip
    BrowserMatch bMSIE !no-gzip !gzip-only-text/html
    </IfModule>
    </IfModule>
    Header append Vary User-Agent env=!dont-vary #############################################################

  • Kris Tomczyk

    Hi Yuriy Petushkov

    I check all images in your Performance Test in Hummingbird and all settings in Smush.

    Some of images from this performance test are no compressed because those are original images used on pages, for ex.:
    images from performance test list 10-18.

    Smush compress only those images you set up in Smush settings.
    Hummingbird Performance Test check all images on site that are used in real.

    I see you have disabled option:
    "Smush my original full-size images"
    If you enable that option this should make score higher for this case.
    I also recommend to combine this option with "Make a copy of my full size images", just in case.

    As for images from this test in list with nr 1-9 I also make some small investigation and it is look those images are to large for container. Let me simplify this a little bit more.

    Hummingbird has two reports for image optimization.

    1. Losslessly compressing - This one's is telling that image can be optimized, that's what smushing takes care of and there are no such reports on your site.

    2. Compressing and resizing - This tells us that image is larger than its actual HTML holder.

    The second one is what's shown in your results and that's because your theme is loading images larger than it's HTML holder, for example Shop_panorama.jpg is a 4944x1539 image loaded but the actual HTML holder of that image is only 1350x550 so the image is resized with CSS to fit in that holder.

    Unfortunately this is not Hummingbird can deal with since your theme or slider code is written in the way to call the larger image, and even though the image is compressed Hummingbird doesn't like loading image larger than its holder.

    There are three option to fix this:

    1. Enable in Smush "Resize my full size images" and set up max Max width for future images you will add to site.

    2. Optimize/resize those images manually on PC to correct size (each image) and reupload/overwrite them again to correct folders via FTP.

    3. Use default Worpdress resize option in library:
    - Go to Media -> Library
    - search you image in search box
    - hover on image and click edit
    - then click "Edit Image" button
    - you should see then "Scale Image" box where you can set new dimensions for your image/images.

    Hope this help :slight_smile:

    Have a great weekend,
    Kris

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.