Hummingbird gzip error

Hi WPMU Team,

try do work with Hummingbird.
Started with Gzip compresses and got errors.
"gzip is not working properly:
- Your server may not have the "deflate" module enabled (mod_deflate for Apache, ngx_http_gzip_module for NGINX)
- Another plugin may be interfering with the configuration"

My hosting wrote something about kompression. Seems similar
https://wiki.uberspace.de/webserver:htaccess#kompression

What can I do to solve?
Access is granted

Best regards from Bavaria
Manfred :slight_smile:

  • Manfred_Huber
    • Design Lord, Child of Thor

    Hi Luis,
    it is allowed to do it in my shared hosting.
    But I have to copy the default php.ini into my account.
    But if my hoster do some global changes, my local php.ini will not be updated.
    My technical skills are not so deep to understand the possible consequences.

    So, my solution for the moment is to try it with another plugin like "WP-Super-Cache"
    I will need anyway a server caching plugin together with humingbird.

    Whad do you think, any comments or better solutions?

    Best regards from Munich
    Manfred :slight_smile:

  • Luís
    • Support

    Hi Manfred_Huber ,

    Hope you're doing well today!

    Changes made in the php.ini should override the server configurations (if you are allowed to do that).

    Some host providers don't allow changes using php.ini, but if you are allowed (and from the article you shared, seems that you can) the changes made by them will not interfere.

    However, maybe the best option should be contact them, just to make sure.

    So, my solution for the moment is to try it with another plugin like "WP-Super-Cache"
    I will need anyway a server caching plugin together with humingbird.

    Hummingbird don't have a full page cache feature as WP Super Cache, only Browser Caching, so, both plugin can be used alongside.

    You can try enable the GZIP Compression through WP Super Cache, however, I am not sure if it will work, as you are having issues with Hummingbird in this feature.

    I hope this information has been helpful. If I can help you in this or other questions, please let me know!

    Cheers, Luís

  • Manfred_Huber
    • Design Lord, Child of Thor

    Hi Luis,

    I tried WP-Super-Cache for compression but had some strange behaviors.

    So lets come back to the Hummingbird.

    Same error with php.ini and "zlib.output_compression = On" - PHPVERSION=5.6

    In attach you can find .htaccess file

    Best regards from Bavaria
    Manfred :slight_smile:

  • Luís
    • Support

    Hi Manfred_Huber ,

    Hope you're doing well today!

    I checked your website and seems the GZIP compression is enabled. You can test it using an external tool, like:

    https://checkgzipcompression.com/

    However, seems that is only enabled to "text/html". The .htaccess was not uploaded, maybe because the attachments don't allow the ".htaccess" extension, so, you will need to save the file as ".txt" and then try upload it again.

    Also, try add this code to your .htaccess:

    <ifModule mod_deflate.c>
    
    <FilesMatch "\.(css|js|x?html?|php)$">
    
    SetOutputFilter DEFLATE
    
    </FilesMatch>
    </ifModule>

    Cheers, Luís

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.