[Hummingbird] Gzip is not working properly

Gzip is not working properly. I chose server type as Apache but still happen. Pls me fix this issue

  • Adam Czajczyk

    Hello hek

    I hope you're well today and thank you for your question!

    I understand that you do have a .htaccess file for your site and when you go to "WPMU DEV -> Support" page, click on "System info" button and switch to "Server" tab there, it does report server as Apache. Is that correct?

    When I checked your site from outside it doesn't seem to be "Gzip compressed" indeed but also the server that responds directly to the query is NGINX. Your site seems to be hosted by SiteGround so if it's a shared hosting account I doubt you got an access to NGINX configuration.

    In this case, you might need to either look through the SiteGround hosting panel to see if there are any options to enable GZIP compression there or contact SiteGround directly and ask them about this.

    The issue here is that the server configuration seems (though not having full access to the site and server I cannot confirm that for sure) to be this way: there's an Apache server directly powering your site but "in front of it" (so between your site and the browser) there's NGINX server acting as some sort of reverse proxy and/or load balancer.

    This is quite a common configuration due to its speed, stability and security benefits. However, the downside is that in such case a GZIP compression should be enabled in NGINX configuration and not in Apache configuration. While that's not a big issue with VPS or dedicated servers where you do have a full access to NGIX config, it might be different on shared hosts where you can only affect some aspects of Apache configuration.

    In most cases like this, GZIP compression should be enabled by default in NGINX. It might be enabled for just some specific MIME types, though.

    Having that said, I think you should start with checking your host management panel to see if there are any options to enable GZIP compression and if not, please get in touch with your host and ask them if they can confirm the configuration (nginx being "in front" of apache) and if so, if there's any way for you to enable that compression in NGINX settings.

    Let me know about their response, please.

    Kind regards,
    Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.