[Hummingbird] Gzip is not working properly:

Aaron Bryson 08:26:33 am

Gzip is not working properly:

- Your server may not have the "deflate" module enabled (mod_deflate for Apache, ngx_http_gzip_module for NGINX).
- Contact your host. If deflate is enabled, ask why all .htaccess or nginx.conf compression rules are not being applied.

Hi Matt, my HTML Gzip is not working properly 08:27:18 am
https://www.dropbox.com/s/cl64wonj2r4f4s8/Screenshot%202018-06-09%2008.27.59.png?dl=0 08:28:13 am

Matt Vincent 08:28:39 am

Hello Aaron, I see your note. Where are you seeing this message generated? I can make a php.info page to show you which modules are active. However I believe gzip compression is enabled (not for staging) and also I would not be able to make any modification to the server such as applying those changes.
Which URL were you testing that on? 08:29:05 am

Aaron Bryson 08:29:24 am

https://www.istoregreenville.com/wp-admin/admin.php?page=wphb-gzip
For istoregreenville.com
Is the server NGINX? 08:30:16 am

Matt Vincent 08:30:26 am

Nginx is part of it yes.
Give me one moment here to make that php.info page.

Aaron Bryson 08:30:44 am

# Enable Gzip compression
gzip on;

# Compression level (1-9)
gzip_comp_level 5;

# Don't compress anything under 256 bytes
gzip_min_length 256;

# Compress output of these MIME-types
gzip_types
application/atom+xml
application/javascript
application/json
application/rss+xml
application/vnd.ms-fontobject
application/x-font-ttf
application/x-font-opentype
application/x-font-truetype
application/x-javascript
application/x-web-app-manifest+json
application/xhtml+xml
application/xml
font/eot
font/opentype
font/otf
image/svg+xml
image/x-icon
image/vnd.microsoft.icon
text/css
text/plain
text/javascript
text/x-component;

# Disable gzip for bad browsers
gzip_disable "MSIE [1-6]\.(?!.*SV1)";
For NGINX servers:

Copy the generated code into your nginx.conf usually located at /etc/nginx/nginx.conf or /usr/local/nginx/conf/nginx.conf
Add the code above to the http or inside server section in the file.
Reload NGINX.
If you do not have access to your NGINX config files you will need to contact your hosting provider to make these changes.
I do not have access to the NGINX config files 08:31:38 am

Matt Vincent 08:33:51 am

Correct, got that page made let me take a look here and see.

Aaron Bryson 08:34:18 am

Thank you Matt.

Matt Vincent 08:38:36 am

Can you give me the link you used to test this on, what i've done is applied this nginx rule to my own install before applying it to yours, I was afraid the regen would fail and break the site. So now I would like to test my own URL to see if I get different results than the ones from your previous screenshot. Just need to know where to go to test that now.

Aaron Bryson 08:38:54 am

https://www.istoregreenville.com/wp-admin/admin.php?page=wphb-gzip
It also read Gzip is not working properly:

- Your server may not have the "deflate" module enabled (mod_deflate for Apache, ngx_http_gzip_module for NGINX).
- Contact your host. If deflate is enabled, ask why all .htaccess or nginx.conf compression rules are not being applied. 08:42:59 am
If re-checking and restarting does not resolve, please check with your host 08:43:33 am

Matt Vincent 08:43:59 am

Understood, checking now on my own install. So Id need to install Hummingbird correct? Is this the paid version you are using or the free version?

Aaron Bryson 08:44:19 am

Yes, it is the paid version

Matt Vincent 08:49:45 am

Gotcha, so what I am seeing is that Gzip is enabled on the server. However using that specific plugin would require certain configuration or code (I believe what you provided me) I am going to add that, but I am taking a backup before just incase.

Aaron Bryson 08:50:16 am

Thank you that sounds like a solid plan.

Matt Vincent 08:53:23 am

So I am not sure if I need to log out and log back in, or 're scan' using that plugin but I refreshed the page and I still see the message about HTML
Are you seeing the same?

Aaron Bryson 08:54:53 am

I am still seeing it. It's strange as I have been using it since I have used WPEngine for hosing and this error just popped up
It seems to think the Server is Apache instead of NGINX 08:55:42 am
For NGINX servers:

Copy the generated code into your nginx.conf usually located at /etc/nginx/nginx.conf or /usr/local/nginx/conf/nginx.conf
Add the code above to the http or inside server section in the file.
Reload NGINX.
If you do not have access to your NGINX config files you will need to contact your hosting provider to make these changes.

Still having trouble? Start a live chat.

# Enable Gzip compression
gzip on;

# Compression level (1-9)
gzip_comp_level 5;

# Don't compress anything under 256 bytes
gzip_min_length 256;

# Compress output of these MIME-types
gzip_types
application/atom+xml
application/javascript
application/json
application/rss+xml
application/vnd.ms-fontobject
application/x-font-ttf
application/x-font-opentype
application/x-font-truetype
application/x-javascript
application/x-web-app-manifest+json
application/xhtml+xml
application/xml
font/eot
font/opentype
font/otf
image/svg+xml
image/x-icon
image/vnd.microsoft.icon
text/css
text/plain
text/javascript
text/x-component;

# Disable gzip for bad browsers
gzip_disable "MSIE [1-6]\.(?!.*SV1)"; 08:56:08 am

Matt Vincent 09:00:23 am

So it sounds like you would need to add those into .htaccess. If the message is bringing up apache not nginx it is possible the conf file isnt being read and so the changes would need to be made in .htaccess
I will be honest that this is not something we would be able to offer any support on however I do have an article (near the bottom) is a code block that may help with adding that compression to gzip specifically for HTML files. 09:01:01 am
https://kinsta.com/knowledgebase/enable-gzip-compression/