[Hummingbird] Gzip not working despite the fact that it is included in my .htaccess file

I enabled Gzip compression but I kept seeing an error message that mod_deflate isnt enabled on my server. I contacted my hosting company (Ipage) and they told me it is enabled.

Here is the error message:
--

Gzip is not working properly:

- Your server may not have the "deflate" module enabled (mod_deflate for Apache, ngx_http_gzip_module for NGINX).
- Contact your host. If deflate is enabled, ask why all .htaccess or nginx.conf compression rules are not being applied.

If re-checking and restarting does not resolve, please check with your host or open a support ticket with us.