[Hummingbird] GZIP setting no longer working through hummingbird

Gzip compression setting no longer shows as working yet nothing has changed on server or website, just updated hummingbird plugin. Support access turned on.

  • Patrick Freitas

    Hi Richard Alva

    How are you today?

    I had a close look to the problem, it appear you don't have the "deflate" module enabled in the server account and the HTML is not being compressed, I checked the GTMETRIX site and the CSS and JS seems to be working.
    You can find the report here: https://gtmetrix.com/reports/mccallrockplacing.com/j0FVUfMk

    However I would suggest to try enable it using the .htaccess file to make sure that everything will be compressed.

    Remember, is better to do this test on a staging website, if you can't do it, please perform a full backup.

    Wouldn't you mind please log in in the WordPress root folder using FTP credentials or by the web hosting Panel, make sure that all hidden content is marked to showing, if it doesn't, please enable the option to show hidden content, unfortunately the steps to enable it, will depends which way you are accessing by.

    In the WordPress root Folder search for .htaccess file, please provide a backup for this file, you can download it or copy and rename to .htaccess-temp for example.

    Click to edit .htaccess and past the following code bellow the all content:

    <IfModule mod_deflate.c>
    	SetOutputFilter DEFLATE
        <IfModule mod_setenvif.c>
            <IfModule mod_headers.c>
                SetEnvIfNoCase ^(Accept-EncodXng|X-cept-Encoding|X{15}|~{15}|-{15})$ ^((gzip|deflate)\s*,?\s*)+|[X~-]{4,13}$ HAVE_Accept-Encoding
                RequestHeader append Accept-Encoding "gzip,deflate" env=HAVE_Accept-Encoding
            </IfModule>
        </IfModule>
        <IfModule mod_filter.c>
            AddOutputFilterByType DEFLATE "application/atom+xml" \
                                          "application/javascript" \
                                          "application/json" \
                                          "application/ld+json" \
                                          "application/manifest+json" \
                                          "application/rdf+xml" \
                                          "application/rss+xml" \
                                          "application/schema+json" \
                                          "application/vnd.geo+json" \
                                          "application/vnd.ms-fontobject" \
                                          "application/x-font-ttf" \
                                          "application/x-font-opentype" \
                                          "application/x-font-truetype" \
                                          "application/x-javascript" \
                                          "application/x-web-app-manifest+json" \
                                          "application/xhtml+xml" \
                                          "application/xml" \
                                          "font/eot" \
                                          "font/opentype" \
                                          "font/otf" \
                                          "image/bmp" \
                                          "image/svg+xml" \
                                          "image/vnd.microsoft.icon" \
                                          "image/x-icon" \
                                          "text/cache-manifest" \
                                          "text/css" \
                                          "text/html" \
                                          "text/javascript" \
                                          "text/plain" \
                                          "text/vcard" \
                                          "text/vnd.rim.location.xloc" \
                                          "text/vtt" \
                                          "text/x-component" \
                                          "text/x-cross-domain-policy" \
                                          "text/xml"
    
        </IfModule>
        <IfModule mod_mime.c>
            AddEncoding gzip              svgz
        </IfModule>
    
    </IfModule>

    Log in back to WordPress dashboard > Hummingbird > GZIP Compression > and click to RE-CHECK STATUS

    You should now get the GZIP Compression working, please let me know the results and any further question that you may have.

    Have a great day,
    Best Regards,
    Patrick Freitas

  • Richard Alva

    Yes, thanks, that’s not the issue, you can see here that all is installed:

    https://mccallrockplacing.com/p.info.php

    Also, that code is already in the .htaccess file and Google page speed insights shows compressions enabled and working. So the issue appears to be Hummingbird not able to verify that. Please figure out why hummingbird is showing that error when everything is working, thank you.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.