Hummingbird .htaccess error is... um... in error?

Hummingbird is throwing an error, saying it can't access the .htaccess file. However, the file is updated and no conflicting plugins are present. To see if it may be an Apache error, I tested the site with the following results from my terminal:

Terminal Input:
curl -I --compress http://www.mrpr.com

Terminal Output:

HTTP/1.1 200 OK
Server: Apache/2.2
Vary: User-Agent,Accept-Encoding
Content-Type: text/html; charset=UTF-8
Content-Encoding: gzip
Date: Fri, 26 Feb 2016 16:27:10 GMT
X-Pingback: http://www.mrpr.com/xmlrpc.php
Link: <http://www.mrpr.com/wp-json/>; rel="https://api.w.org/"
Link: <http://www.mrpr.com/>; rel=shortlink
Connection: Keep-Alive
Set-Cookie: X-Mapping-jfocjcpm=10B5413143EFB4B443B84786541BFE67; path=/
Content-Length: 20
  • Michael Bissett

    Hey Aqaba Technologies, Michael here!

    I'll want to have a deeper look at things here, could you please send in the following via our secure contact form:

    - Mark to my attention, the subject line should contain only: ATTN: Michael Bissett
    - Do not include anything else in the subject line, doing so may delay our response due to how email filtering works.
    - Link back to this thread
    - Include WordPress admin access details (login address, username & password)
    - Include FTP log-in details (hostname, username & password)
    - Include any relevant URLs/details for your site (e.g. where you're seeing the error come up in Hummingbird)

    IMPORTANT: Please make sure you select "I have a different question" for your topic, so it doesn't go back to the forums - this and the subject line ensure that it gets assigned to me.

    https://premium.wpmudev.org/contact/

    Kind Regards,
    Michael

  • Michael Bissett

    Hey Aqaba Technologies, thanks for sending in those details! :slight_smile:

    I've tried disabling & re-enabling the "Browser Caching" & "GZIP Compression" options (as those would modify the .htaccess file), but I've found myself able to do so without any errors coming up, are you still running into this?

    If so, I'd like to know:
    - The browser in question (the version too)
    - The operating system it's running on
    - What I'd need to do to replicate your situation

    Hope you're doing well! :slight_smile:

    Kind Regards,
    Michael

    Edit: Okay, just started running into this right after I posted this, stay tuned for more...

    Edit #2: Okay, that error's gone now, but then this popped up:

    Browser Caching is not working properly:
    - Your server may not have the "expires" module enabled (mod_expires for Apache, ngx_http_headers_module for NGINX)
    - Another plugin may be interfering with the configuration

    After refreshing the permalink structure over in:

    Settings -> Permalinks

    That notice went away for me. Can you confirm the same on your end please?

  • Michael Bissett

    Ah, shoot! Thought I'd moved them back over when I left, guess this was the one time that I'd missed that. Sorry about that! :slight_frown:

    I create a 000-disable-plugins folder to easily handle the disabling of plugins via FTP, moving the plugins back and forth in the process of checking for conflicts (testing to see if there's a particular plugin, that when active, might cause a hiccup).

    I trust that you were able to get that sorted then? What were the results of your testing?

    Please advise,
    Michael

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.