[Hummingbird] Humingbird Lost Her Shirt?

Was checking out the error_log, and found a bunch of these happening now,
[15-Jun-2018 15:04:04 UTC] PHP Warning: file_get_contents(): https:// wrapper is disabled in the server configuration by allow_url_fopen=0 in /home/mplawhost/public_html/wp-content/plugins/wp-hummingbird/core/modules/minify/class-minify-group.php on line 1349
[15-Jun-2018 15:04:04 UTC] PHP Warning: file_get_contents(https://hb.wpmucdn.com/matthewpillado.com/d469f392-6f8c-4d11-a732-adb9b0dd7e53.css): failed to open stream: no suitable wrapper could be found in /home/mplawhost/public_html/wp-content/plugins/wp-hummingbird/core/modules/minify/class-minify-group.php on line 1349

Should I be worried?
Matthew

Found some more in a different error_log too,

[15-Jun-2018 15:04:10 UTC] PHP Warning: Illegal string offset 'unslider' in /home/mplawhost/public_html/wp-content/plugins/wp-hummingbird/core/modules/minify/class-minify-group.php on line 429
[15-Jun-2018 15:04:10 UTC] PHP Warning: Illegal string offset 'unslider' in /home/mplawhost/public_html/wp-content/plugins/wp-hummingbird/core/modules/minify/class-minify-group.php on line 450
[15-Jun-2018 15:04:11 UTC] PHP Warning: Illegal string offset 'unslider' in /home/mplawhost/public_html/wp-content/plugins/wp-hummingbird/core/modules/minify/class-minify-group.php on line 429
[15-Jun-2018 15:04:11 UTC] PHP Warning: Illegal string offset 'unslider' in /home/mplawhost/public_html/wp-content/plugins/wp-hummingbird/core/modules/minify/class-minify-group.php on line 450

  • James Morris
    • WordPress Enthusiast

    Hello Matthew

    The file_get_contents() issue is a known one. Basically, if you have allow_url_fopen = Off in your php configuration then this error will occur. The simple solution is to set allow_url_fopen = On. However, our Dev Team is working on a solution for future versions that will not require this.

    The PHP Warning: Illegal string offset 'unslider' is a new one on me. I've yet to see this and cannot find any reports of it in our tracker.

    Could you tell me what version of PHP you are running? Also, could you try fixing the first issue and see if the second issue persists?

    Best regards,

    James Morris

  • Matthew
    • Just Being Me

    I enabled the allow_url_fopen = On property in WHM for ea_php71, that is also the version we are running for everything on the server at this time. There have been no repeats of the error since, I'll keep an eye open.

    Here is a new one today: [Mon Jun 18 15:20:12.121510 2018] [access_compat:error] [pid 9565:tid 140492295563008] [client 162.241.152.104:37238] AH01797: client denied by server configuration: /home/mplawhost/public_html/wp-content/plugins/wp-hummingbird/core/modules/dummy/dummy-php.php, referer: https://matthewpillado.com/wp-content/plugins/wp-hummingbird/core/modules/dummy/dummy-php.php

  • James Morris
    • WordPress Enthusiast

    Hello Matthew

    In order to help you better with your issue, would you please grant me access to your site and server so I can perform some advanced debugging?

    NOTE: Please make a full backup of your site before sending the following information.

    Please visit the Contact page and complete the form with the following information:

    https://premium.wpmudev.org/contact/#i-have-a-different-question

    Option: I have a different Question

    Subject: "Attn: James Morris"

    In the Message box, please provide the following:

    - link back to this thread for reference
    - any other relevant urls

    - Admin login:
    Admin username
    Admin password
    Login url

    - Hosting Control Panel Login (WHM/cPanel)
    Admin username
    Admin password
    Login url

    Best regards,

    James Morris

  • James Morris
    • WordPress Enthusiast

    Hello Matthew

    Thank you for sending that in. I've checked your site and this issue was being cause by the Defender Prevent PHP execution tweak. Adding the following to wp-content/.htaccess resolves this.

    <Files "dummy-php.php">
        Order Allow,Deny
        Allow from all
    </Files>

    Though, it shouldn't be needed in production. In fact, the file being referenced is only for testing and can safely be ignored.

    However, you may want to save that snippet above as it may be needed in the future for allowing front-end access to specific php files inside wp-content/ :wink:

    I hope this clarifies a bit.

    Best regards,

    James Morris

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.