[Hummingbird] hummingbid - assets not blocking rendering

asset optimization does not seem to be deferred loading / not render blocking as far as what google is showing:
https://developers.google.com/speed/pagespeed/insights/?url=http%3A%2F%2Fsextipcams.com%2F

eg:
.com/…codes/styles/bootstrap.min.css?ver=4.9.5
.com/…es/styles/font-awesome.min.css?ver=4.9.5
.com/…/admin/assets/css/critical.css?ver=4.9.5
.com/…form-7/includes/css/styles.css?ver=5.0.1
.com/…gins/page-list/css/page-list.css?ver=5.1
.com/…tent/themes/pinblack/style.css?ver=4.9.5
om/…/themes/pinblack/library/css/default.css
pretty sure I set things to be deferred.. is there some css that I need to inline that I am missing or something?
https://developers.google.com/speed/docs/insights/OptimizeCSSDelivery

  • Anton Vanyukov

    Hi djsteve,

    Defer option works only for JavaScript files. For CSS you have the option to inline.

    Regarding your issue. It looks like you have ajax loading of content. And it seems that Google PageSpeed is missing that. When the page is loaded without additional ajax content, it doesn't really matter where the assets are, they will all be above the fold. You can ignore the warnings. Or you can make more content visible on the page by default.

    If you want to improve your score a bit more, you can try and combine CSS and JS files (except the inlined/deferred ones), that will decrease the number of "problematic" assets. But please test proper functionality by combining one asset at a time and checking that the frontend loads without any issues.

    Hope this helps.

    Best regards,
    Anton

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.