[Hummingbird] Hummingbird and Divi theme caching problem

I've experienced a issue on two sites concerning Hummingbird on sites with the Divi theme.

Repeatidly the site will stops loading the style.css from the child theme.

If I clear cache, all returns to normal but that never lasts. I disabled the cache on the andisondesign.com website a while back and the issue has not happened since.

  • Adam Czajczyk

    Hello Lawrence

    Thanks for granting support access.

    I have enabled Page Caching in Hummingbird on your site (along with its debug option) and then browsed your site - as a visitor - for a while. I used both regular and incognito modes in browser, also tried with browser cache disabled in browser entirely, but I wasn't able to notice the issue.

    I assume that I might have missed some crucial step during testing or I'd need to do it for a bit longer time maybe? Could you suggest some "testing procedure" that I should follow to be able to actually see the issue on your site? I'll be happy to test it again and investigate the case then but it's essential for me to first encounter the issue on your site, I hope that makes sense :slight_smile:

    Looking forward to your response,
    Adam

  • Lawrence

    Hi Adam!

    It doesn't happen immediately. I first noticed it when the client called stating some of the site's links etc were, "Blue and the text was different (non-italicized)". I couldn't pinpoint what it was but then just as a, "Let's give this a try!" I cleared the cache in Hummingbird. That worked and got it back to what it was supposed to be.

    I let it be but later on (days maybe even weeks) later got a call from the client that it had happened again. Once again, clearing cache remedied the issue. This has happened multiple times with this client until I decided to see if it was a caching issue and disabled it.

    I then had another client (also using Divi and Hummingbird) said his site "Looked like something was missing." After a second of looking at the site and wondering why it looked off, it occurred to me it may be the same issue. So I cleared the cache and it too solved the issue.

    Like I mentioned, it's just the child theme CSS that seems to not get loaded. The parent theme styles kick in. I'm using the CDN on both sites as well and wondered if that had anything to do with it.

    Thanks,

    Lawrence

  • Baldafrican

    Hi Lawrence ,

    I hope you don't mind me chiming in here but I did notice that you stated it is a Divi site. Could you check your settings in your Divi Theme Options and compare them to sites that are not experiencing the issue?

    The settings to focus on are;

    General -> Minify and Combine Javascript Files
    General -> Minify and Combine CSS Files
    Builder -> Static CSS File Generation
    Builder -> Output Styles Inline

    I have had similar issues in the past and depending on server setup, playing with these settings usually helped solve the issue.

    Hope you have a similar successful result.

  • Adam Czajczyk

    Hello Lawrence

    I think Baldafrican (thanks Mike!) raised the valid point here!

    I see that all these settings are enabled currently but since you're using Hummingbird's Asset Optimization as well, at least those two in "General" section should be disabled. If you disable them, make sure that you also go to "Asset Optimization" settings and re-check and re-configure (if necessary) settings there.

    I'd start with that and then enabled cache back to see if that helps and if it doesn't, then also "experiment" with "Builder" settings (though, unlike "General" minification options that should be disabled, there is no straight rule here I think).

    Keep us informed about results, please.

    Best regards,
    Adam

  • Lawrence

    Hey guys! Sorry for the late reply... I'd forgotten about this as the site in question has had no problems since! I checked another Divi site today and it had done the same. That's when I remembered this and came back.

    I've just turned off all the Divi settings mentioned above, cleared cache etc and have left all the minifying etc to Hummingbird. I hope that all will be good going forward!

    I'll come back and report!

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.