[Hummingbird] Hummingbird Cache is preventing Image Gallery from loading

I've noticed a recurring issue with my image galleries on project pages for this site. The rest of the page will load, but the image gallery will not. When I go into my admin panel and reset the cache, the image gallery starts loading again. It works for a couple days/weeks and then it stops again. i've seen other forum posts with similar issues regarding other caching plugins preventing image galleries from functioning correctly. Is there a way to avoid this that you know of? Or a way to force the cache to reset once every week or two so it automatically clears out whatever is causing the error in the cache?

  • James Morris

    Hello Rob

    I hope you are well today.

    Our records are showing that the site you associated with this ticket is currently on Hummingbird Version: We are now currently on version 1.8.1 (updated April 12, 2018). There's been a great deal of improvements and patches applied to Hummingbird since

    To ensure that we're not trying to troubleshoot an issue that's already been resolved in previous patches, would you please upgrade to the latest version, clear all caches and see if the issue persists?

    If the issue is still present, would you please grant me access to your site?

    You can learn how to grant WPMU DEV Support Access at the following link:


    Please reply back here once you've enabled access so I will be notified.

    Best regards,

    James Morris

  • Rob

    Hey James, I'm trying to update the plugins, and it won't update when I'm on my site. When I login to the hub and try to update I get a message that reads "We got an unexpected response from your website: " with no further details.

    This error pops up whether I am updating Hummingbird or the WPMU dashboard plugin.

    I'm going to have to setup a new staging site before providing access, but wasn't sure if you could see any other details on the log than that error message. It's pretty obscure so not sure what to look at. I thought maybe it was a PHP timelimit, but even after bumping that up to 150 it's still showing the error within a few seconds of clicking update.

    I also tried updating hummingbird on another site on the same server with no problems at all.

  • James Morris

    Hello Rob

    Sounds like there might be a conflict somewhere. Would you please try manually installing the plugin via FTP and see if this resolves the issue.

    - First, please make a full backup of your site in case you need to roll back your changes
    - Go to https://premium.wpmudev.org/project/wp-hummingbird/ and download the latest version
    Screenshot: http://storage5.static.itmages.com/i/18/0417/h_1523951823_4845717_7640eef826.png
    - Go to WP Admin -> Plugins and Deactivate Hummingbird Pro
    - Login to your site via FTP and navigate to wp-content/plugins/
    - Delete the wp-hummingbird folder
    - Extract the zip archive containing the latest version of Hummingbird
    - Upload the latest version to your server to wp-content/plugins/
    - Go to WP Admin -> Plugins and Activate Hummingbird Pro

    Let us know if you have any further issues.

    Best regards,

    James Morris

  • Rob

    Hi James, When I attempt this, I was able to remove the old version, but I can not activate the new version after uploading. I receive the following fatal error message:

    Please note I can not tell if this support ticket is visible to the public or not so I've replaced my site directory with ***


    Warning: include_once(): Failed opening '/home/***/public_html/wp-content/plugins/wp-hummingbird/helpers/wp-hummingbird-helpers-core.php' for inclusion (include_path='.:disappointed:opt/cpanel/ea-php70/root/usr/share/pear') in /home/***/public_html/wp-content/plugins/wp-hummingbird/core/class-installer.php on line 29

    Warning: include_once(): Failed opening '/home/***/public_html/wp-content/plugins/wp-hummingbird/helpers/wp-hummingbird-helpers-settings.php' for inclusion (include_path='.:disappointed:opt/cpanel/ea-php70/root/usr/share/pear') in /home/***/public_html/wp-content/plugins/wp-hummingbird/core/class-installer.php on line 31

    Warning: include_once(): Failed opening '/home/***/public_html/wp-content/plugins/wp-hummingbird/helpers/wp-hummingbird-helpers-cache.php' for inclusion (include_path='.:disappointed:opt/cpanel/ea-php70/root/usr/share/pear') in /home/***/public_html/wp-content/plugins/wp-hummingbird/core/class-installer.php on line 33

    Warning: include_once(): Failed opening '/home/***/public_html/wp-content/plugins/wp-hummingbird/helpers/wp-hummingbird-helpers-modules.php' for inclusion (include_path='.:disappointed:opt/cpanel/ea-php70/root/usr/share/pear') in /home/***/public_html/wp-content/plugins/wp-hummingbird/core/class-installer.php on line 35

    Fatal error: Uncaught Error: Call to undefined function wphb_has_cloudflare() in /home/***/public_html/wp-content/plugins/wp-hummingbird/core/class-installer.php:45 Stack trace: #0 /home/***/public_html/wp-content/plugins/wp-hummingbird/wp-hummingbird.php(370): WP_Hummingbird_Installer::activate() #1 /home/***/public_html/wp-includes/class-wp-hook.php(298): wphb_activate('') #2 /home/***/public_html/wp-includes/class-wp-hook.php(323): WP_Hook->apply_filters('', Array) #3 /home/***/public_html/wp-includes/plugin.php(453): WP_Hook->do_action(Array) #4 /home/***/public_html/wp-admin/plugins.php(166): do_action('activate_wp-hum...') #5 {main} thrown in /home/***/public_html/wp-content/plugins/wp-hummingbird/core/class-installer.php on line 45

  • James Morris

    Hello Rob

    In order to help you better with your issue, would you please grant me access to your site and server so I can perform some advanced debugging?

    NOTE: Please make a full backup of your site before sending the following information.

    Please visit the Contact page and complete the form with the following information:


    Option: I have a different Question

    Subject: "Attn: James Morris"

    In the Message box, please provide the following:

    - link back to this thread for reference
    - any other relevant urls

    - Admin login:
    Admin username
    Admin password
    Login url

    - Hosting Control Panel Login
    Admin username
    Admin password
    Login url


    - FTP credentials
    (and port if required)

    Best regards,

    James Morris

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.