[Hummingbird] Hummingbird : cannot activate resource optimization

Hi.
I need to optimize my website (because of render blocking resources warnings), but cannot activate resource optimization in Hummingbird pro. Can you help ? I click on the "activate" button, file-check happens, and I'm back to the "activate" button page. I cannot access the advanced mode where I can manage individual resources.
I tried debug mode, no message.

  • Predrag Dubajic
    • Support

    Hi Fred,

    Hope you're doing well.

    I was looking at your site and while trying to activate Asset Optimization there were some errors showing up in console, it was showing 200 error for admin-ajax.php like there's something preventing access to that file and it might be the cause of this issue.

    Can you try disabling Wordfence plugin and check with your host if there's anything in server logs about admin-ajax.php being blocked?
    If there is ask them to allow access and then give it another try.

    Let us know how it goes.

    Best regards,
    Predrag

  • Fred Reillier
    • Design Lord, Child of Thor

    Hi.
    I"ve disabled Wordfence and other plugins with no result.
    For my host blocking resources; there is no indication that this happens. Also, I have a few client websites at the same hosting company on similar packages, and Hummingbird works perfectly on them.

  • Predrag Dubajic
    • Support

    Hi Fred,

    Does this installation have any specific plugin that's not running on your other sites?
    The 200 error for admin-ajax is still there, and it looks there's something on this site that's causing it.
    Could you perform a troubleshooting test by disabling all other plugins and try activating Asset Optimization after that?
    If it works, then you can activate them one by one until you find which one is causing this, and once we know which one is causing the conflict we can debug this further from our end.

    Best regards,
    Predrag

  • Predrag Dubajic
    • Support

    Hi Fred,

    Thanks for the info and testing this.

    I believe I will need to ping our dev guys to investigate this further and check what might be going on.
    Could you provide me with FTP or cPanel access so our devs can check this in more depth?

    Note: Don't leave your login details in this ticket.
    Instead, you can send us your details using our contact form https://premium.wpmudev.org/contact/#i-have-a-different-question and the template below:

    Subject: "Attn: Predrag Dubajic"
    - Site login URL
    - WordPress admin username
    - WordPress admin password
    - FTP credentials (host/username/password)
    - cPanel credentials (host/username/password)
    - Folder path to site in question
    - Link back to this thread for reference
    - Any other relevant urls/info

    Please respond here after these are sent so I can make sure they are properly received.

    Best regards,
    Predrag

  • Predrag Dubajic
    • Support

    Hi Fred,

    Our devs had a look at your site and the issue seems to be indeed with the 200 error that happens on each page of your admin section.
    The thing is that this error is not caused by HB as it's happening even when the plugin is disabled.
    But the error does happen on all your pages in admin, including Asset Optimization, so the scripts need for HB to finish up the optimization process get broken as well.

    So I'm afraid that you will first need to find the cause of that admin-ajax error in order to get Asset Optimization to work.
    I still think that it's most likely caused by something installed on your site and full conflict would be the best way to figure this out, my suggestion is to do it on staging site so you can completely remove the options and settings written by theme/plugins installed.

    Or have another discussion with your hosting provider in order to double check if there's anything in server logs about this error.

    Best regards,
    Predrag

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.