[Hummingbird] issue with load times using humminbird

when running some speed test is get BAR results because of humming bird
for example:
There are 25 JavaScript files served from domain.com FIx: Combine external file

example:
domain.com/wp-content/uploads/hummingbird-assets/0fc0d576f39edc90d44e0f91e3fe1ee1.css/hummingbird-assets/91b5ab0b68f92b148a5c8991a1e63ffe-1.js

This page makes 62 parallelizable requests to domain.com Increase download parallelization by distributing these requests across multiple hostnames:
example:
wp-content/uploads/hummingbird-assets/1f3f4dbc534c4334b682542e712db48f-1.js

so looks like hummingbird is causing more harm (in speed test) than good?

The web page took 4.30 s to load, used 124 requests, and weighed in at 2.1 MB.
The Google Page Speed performance grade for this web page is 65/100.
There’s a ton of more information you can check out here: https://tools.pingdom.com/#!/bKbRfD/https://nationalblueribbonschools.ed.gov/

  • viobru

    Hi, goldeneye!

    Thanks for contacting us, hope you are doing great :slight_smile:

    I tried to scan the site again on Pingdom Tools, PageSpeed Insights and GTmetrix to check this but seems that the site is not accessible at this moment. For some reason, if trying to access the front-end or the admin I’m getting an ERR_CONNECTION_TIMED_OUT.

    This error is caused when the server is overloaded and the browser can’t get any response from it, as explained on WordPress Codex:
    The connection timed out error appears when your website is trying to do more than your server can manage. It is particularly common on shared hosting where your memory limit is restricted.
    To fix this, please follow the steps suggested here: Connection Timed Out.

    Please, let us know when the site is back so we can continue assisting you with this.

    Kind regards,
    Violeta

  • viobru

    Hi, again!

    Seems that I skipped that the site is only available to the USA and, since I’m not based on it, this is why I was getting that error, sorry for the confusion. I was finally able to access the site to check this.

    I see on Hummingbird Performance Test that the lowest score on the site is for “Improve server response time”, followed by “Remove render blocking resources” and “Leverage browser caching”:

    As suggested by Hummingbird, the score for the server response time can be improved if using a caching tool on the site. I checked it and seems that the site is currently running 2 different plugins for caching: Hummingbird and WP Super Cache.

    Please note that enabling the same feature on different tools can cause issues, so either disable the WP Super Cache plugin or Hummingbird’s Caching feature, then run a new test to check if this helped and please let us know how it went.

    Kind regards,
    Violeta

  • goldeneye

    every test i run says "leverage browser cache"...
    here is a copy of my htaccess file
    as you can see i have the settings in there so i have NO idea what to change

    # BEGIN WP-HUMMINGBIRD-GZIP
    <IfModule mod_deflate.c>
    <IfModule mod_setenvif.c>
    <IfModule mod_headers.c>
    SetEnvIfNoCase ^(Accept-EncodXng|X-cept-Encoding|X{15}|~{15}|-{15})$ ^((gzip|deflate)\s*,?\s*)+|[X~-]{4,13}$ HAVE_Accept-Encoding
    RequestHeader append Accept-Encoding "gzip,deflate" env=HAVE_Accept-Encoding
    </IfModule>
    </IfModule>
    <IfModule mod_filter.c>
    AddOutputFilterByType DEFLATE "application/atom+xml" \
    "application/javascript" \
    "application/json" \
    "application/ld+json" \
    "application/manifest+json" \
    "application/rdf+xml" \
    "application/rss+xml" \
    "application/schema+json" \
    "application/vnd.geo+json" \
    "application/vnd.ms-fontobject" \
    "application/x-font-ttf" \
    "application/x-font-opentype" \
    "application/x-font-truetype" \
    "application/x-javascript" \
    "application/x-web-app-manifest+json" \
    "application/xhtml+xml" \
    "application/xml" \
    "font/eot" \
    "font/opentype" \
    "font/otf" \
    "image/bmp" \
    "image/svg+xml" \
    "image/vnd.microsoft.icon" \
    "image/x-icon" \
    "text/cache-manifest" \
    "text/css" \
    "text/html" \
    "text/javascript" \
    "text/plain" \
    "text/vcard" \
    "text/vnd.rim.location.xloc" \
    "text/vtt" \
    "text/x-component" \
    "text/x-cross-domain-policy" \
    "text/xml"

    </IfModule>
    <IfModule mod_mime.c>
    AddEncoding gzip svgz
    </IfModule>

    </IfModule>
    # END WP-HUMMINGBIRD-GZIP
    # BEGIN WP-HUMMINGBIRD-CACHING
    <IfModule mod_expires.c>
    ExpiresActive On
    ExpiresDefault "access plus 15 days"

    <FilesMatch "\.(txt|xml|js)$">
    ExpiresDefault "access plus 15 days"
    </FilesMatch>

    <FilesMatch "\.(css)$">
    ExpiresDefault "access plus 1 month"
    </FilesMatch>

    <FilesMatch "\.(flv|ico|pdf|avi|mov|ppt|doc|mp3|wmv|wav|mp4|m4v|ogg|webm|aac|eot|ttf|otf|woff|svg)$">
    ExpiresDefault "access plus 1 month"
    </FilesMatch>

    <FilesMatch "\.(jpg|jpeg|png|gif|swf|webp)$">
    ExpiresDefault "access plus 1 month"
    </FilesMatch>
    </IfModule>

    <IfModule mod_headers.c>
    <FilesMatch "\.(txt|xml|js)$">
    Header set Cache-Control "max-age=691200"
    </FilesMatch>

    <FilesMatch "\.(css)$">
    Header set Cache-Control "max-age=691200"
    </FilesMatch>

    <FilesMatch "\.(flv|ico|pdf|avi|mov|ppt|doc|mp3|wmv|wav|mp4|m4v|ogg|webm|aac|eot|ttf|otf|woff|svg)$">
    Header set Cache-Control "max-age=691200"
    </FilesMatch>

    <FilesMatch "\.(jpg|jpeg|png|gif|swf|webp)$">
    Header set Cache-Control "max-age=691200"
    </FilesMatch>
    </IfModule>
    # END WP-HUMMINGBIRD-CACHING

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    # END WordPress

    <IfModule mod_expires.c>
    ExpiresActive On

    # Images
    ExpiresByType image/jpeg "access plus 1 year"
    ExpiresByType image/gif "access plus 1 year"
    ExpiresByType image/png "access plus 1 year"
    ExpiresByType image/webp "access plus 1 year"
    ExpiresByType image/svg+xml "access plus 1 year"
    ExpiresByType image/x-icon "access plus 1 year"

    # Video
    ExpiresByType video/mp4 "access plus 1 year"
    ExpiresByType video/mpeg "access plus 1 year"

    # CSS, JavaScript
    ExpiresByType text/css "access plus 1 month"
    ExpiresByType text/javascript "access plus 1 month"
    ExpiresByType application/javascript "access plus 1 month"

    # Others
    ExpiresByType application/pdf "access plus 1 month"
    ExpiresByType application/x-shockwave-flash "access plus 1 month"
    </IfModule>

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.