Hummingbird issues - can't activate compression

Hi there, I have been advised by Hummingbird that it is unable to activate compression on the website. I have removed any known plugins which also offer compression and I am able to activate compression manually on other sites on this hosting. Im not sure what I should be checking to resolve these issues?

  • Dimitris

    Hey there Anthony Brindley,

    I trust you're well today and thanks for reaching us! :slight_smile:

    I just inspected your site after you kindly grant us support access and I can the error in HummingBird GZIP Compression page.
    Did you try to manually enable gzip?

    Keep in mind to select the appropriate server type. In case you're using Apache, the following snippet in .htaccess (always backup this file before editing) should do the trick

    <IfModule mod_deflate.c>
        <IfModule mod_setenvif.c>
            <IfModule mod_headers.c>
                SetEnvIfNoCase ^(Accept-EncodXng|X-cept-Encoding|X{15}|~{15}|-{15})$ ^((gzip|deflate)\s*,?\s*)+|[X~-]{4,13}$ HAVE_Accept-Encoding
                RequestHeader append Accept-Encoding &quot;gzip,deflate&quot; env=HAVE_Accept-Encoding
            </IfModule>
        </IfModule>
        <IfModule mod_filter.c>
            AddOutputFilterByType DEFLATE &quot;application/atom+xml&quot; \
                                          &quot;application/javascript&quot; \
                                          &quot;application/json&quot; \
                                          &quot;application/ld+json&quot; \
                                          &quot;application/manifest+json&quot; \
                                          &quot;application/rdf+xml&quot; \
                                          &quot;application/rss+xml&quot; \
                                          &quot;application/schema+json&quot; \
                                          &quot;application/vnd.geo+json&quot; \
                                          &quot;application/vnd.ms-fontobject&quot; \
                                          &quot;application/x-font-ttf&quot; \
                                          &quot;application/x-javascript&quot; \
                                          &quot;application/x-web-app-manifest+json&quot; \
                                          &quot;application/xhtml+xml&quot; \
                                          &quot;application/xml&quot; \
                                          &quot;font/eot&quot; \
                                          &quot;font/opentype&quot; \
                                          &quot;image/bmp&quot; \
                                          &quot;image/svg+xml&quot; \
                                          &quot;image/vnd.microsoft.icon&quot; \
                                          &quot;image/x-icon&quot; \
                                          &quot;text/cache-manifest&quot; \
                                          &quot;text/css&quot; \
                                          &quot;text/html&quot; \
                                          &quot;text/javascript&quot; \
                                          &quot;text/plain&quot; \
                                          &quot;text/vcard&quot; \
                                          &quot;text/vnd.rim.location.xloc&quot; \
                                          &quot;text/vtt&quot; \
                                          &quot;text/x-component&quot; \
                                          &quot;text/x-cross-domain-policy&quot; \
                                          &quot;text/xml&quot;
    
        </IfModule>
        <IfModule mod_mime.c>
            AddEncoding gzip              svgz
        </IfModule>
    
    </IfModule>

    Also, please contact your hosting provider to double check that GZIP module is up and running in your server, as the settings set in .htaccess can become overridden in a higher server layer.

    If the issue still continues after all that, then please proceed with a full theme/plugin conflict test as described in a flow chart here (just scroll down a bit) https://premium.wpmudev.org/manuals/using-wpmu-dev/getting-support/

    Look forward for your results on this,
    take care,
    Dimitris :slight_smile:

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.