Hummingbird Minification

Hi, I'm not sure how your plugin works. I keep doing the "compress" on the suggestions when I go to that screen on the Hummingbird plugin, I click "compress" and then "publish changes" however nothing seems to change and every day i go back and the same ones are being suggested as being minified. also, i keep testing the site after i make these changes on https://testmysite.withgoogle.com and it seems the site's performance has even gotten worse. can you assist?

  • Dimitris
    • Support Star

    Hello there Ian Eric,

    hope you're doing good today and thanks for reaching us! :slight_smile:

    I've just inspected Performance Report and Minification pages in your site, after you kindly granted support access and here's my findings.

    1. Minification
    It seems that this is working good. All assets that could be minified are already minified (you can see the compressed file size compared with initial one). The ones that are excluded are either minified already (they have the .min extension in their file) or it's unable to be compressed due to the way the work.

    2. Performance Report
    The lowest score in there is about "Optimize images"

    The first 10 images needs "compressing and resizing".
    The compressing part is what Smush do, but as these are not thumbnail versions of the images, but the full size ones, you should first activate the "Smush my original full-size images" in Smush settings, then re-smush them.
    The "resizing" part means that these images are used inside smaller containers in the website, so it's better to resize them to match their container. So instead of having a image for example that's 1000x1000px and using inside a element that's 200x200px and image gets downscaled, you should resize the initial image, so it's 200x200px. A more detailed guide on this, can be found in next article from our blog:
    https://premium.wpmudev.org/blog/compress-resize-images-wordpress/

    Image #11 is coming from a plugin folder though, not from uploads folder (which is what's being shown in Media library). In order to smush this image, you should go to Smush settings and select the "Directory Smush" functionality on the very bottom of Smush settings screen. https://premium.wpmudev.org/blog/new-smush-feature-directory-smushing/

    Hope that was some help! Let us know if further assistance is required here!

    Warm regards,
    Dimitris

  • Ian Eric
    • New Recruit

    thanks. i will look into this more now. one other question. I am trying to
    use Hummingbird Caching however it tell me i need to disable any other
    caching plugins. i just did that and the error is still there. can you
    tell me what is triggering the issue? thanks!

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.