Hummingbird minification and it keeps on calculating again

i keep on setting up the minification settings, and then for whatever reason hummingbird recalculate everything and i need to start again, and again and again. All changes done are lost after clear the cache in Minification page.

Also, I am using cloudflare and kinsta - is there an advantage in chcking the box : WPMU DEV CDN ?

  • Luís

    Hi Serena ,

    Hope you're doing well today!

    Not sure if was a glitch between Hummingbird and the other cache tools (cloudflare, autoptimize and kinsta cache), but after clear the cache a few times, I am able to do changes in the minification as expected and the changes are kept.

    Can you please give another try and let us know if everything is working as expected now?

    Regarding to your second question:

    Also, I am using cloudflare and kinsta - is there an advantage in chcking the box : WPMU DEV CDN ?

    Well, this may depend on the configuration, but I will suggest you to do some performance tests, enabling WPMUDEV CDN to offload js/css assets and with it disabled, in order to check what will work better for your site.

    I hope this information has been helpful. If I can help you in this or other related question, please let me know!

    Cheers, Luís

  • Serena

    hi
    i've checked on staging and it is not working. I set up no minification but all css and js combined, and js to footer and then i publish.
    Next Hummingbird starts the assessment again, and when done, the only setting is all files minified.
    I'm a bit frustrated, as you can imagine by the overall issue, and the fact that i feel like your proposals are for me to just try again and again and again....

  • James Morris

    Hello Serena,

    I hope you are well today.

    There's a key here... You're using Hummingbird, Cloudflare, Autoptimize and Kinsta cache together. This is not advisable. Reason being is that running multiple tools for performing similar functions almost always results in a conflict.

    Hummingbird has a native Cloudflare module built in which allows you to control your Cloudflare cache directly from Hummingbird itself.

    So, in order to use Hummingbird, I'd recommend disabling your third-party Cloudflare plugin and use the native module in Hummingbird. I recommend disabling Autoptimize plugin entirely as this is known to conflict with Hummingbird. And I would recommend disabling Kinsta cache as well, for testing purposes.

    Next, I'm seeing that you do not have the latest version of Hummingbird installed. Please update to the latest version.

    If you could also provide us access to your site and server, we'd be happy to dig into this issue further for you. :slight_smile:

    Please visit the Contact page and complete the form with the following information:

    https://premium.wpmudev.org/contact/#i-have-a-different-question

    Option: I have a different Question

    Subject: "Attn: James Morris"

    In the Message box, please provide the following:

    - link back to this thread for reference
    - any other relevant urls

    - Admin login:
    Admin username
    Admin password
    Login url

    - Hosting Control Panel Login
    Admin username
    Admin password
    Login url

    ~OR~

    - FTP credentials
    host
    username
    password
    (and port if required)

    Best regards,

    James Morris

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.