Hummingbird Minification issues

Every time I turn on Hummingbird Minification, the Smart Podcast Player stops working in my blog posts. I've tried Excluding it, Including it, moving it to the footer and the head or leaving it in place, and nothing seems to work. I've seen people discussing this with you on Twitter, but can't find a support post or documentation on how to stop this happening. I keep having to disable Hummingbird, but I'd really like to make it work. Any advice, including pointing me to an article about this, would be very much appreciated.

  • Martin

    Hi Ivan, Team,

    I can certainly give you access, but in the past when doing this for other companies, they switched themes and deactivated plugins etc. My site is live, with a steady stream of visitors, so I currently have Hummingbird disabled, and can't really allow it to be turned back on without me being around. It really messes up the web pages sometimes, and I have to quickly clear the cash etc.

    My original message was really to ask first of all if you have any information that I could reference, as I've seen people pinging you about Smart Podcast Player compatibility on Twitter. If you don't have any information you could forward on, I'll have to set up a staging server. I'm actually having trouble getting your Popup Pro plugin to work as well, so I'm going to have to do this either way.

    Let me know if you have any info about the Smart Podcast Player issue, and in the meantime I'll set up a staging server and get back to you.

    Thanks for your help!

  • Martin

    Hi again Ivan and Team,

    I've set up a staging site for you to look at this issue at mbpvest.com. Please make sure you only make changes on this server, and not my main server as that's live.

    Note too that I'm using the SSL certificate from my main site, so you'll see the security warning when you login or visit the site. It's safe to click OK or whatever and proceed.

    I've also tried deactivating all other plugins, and I still can't get the Smart Podcast Player to display in my blog posts. You can see this here: https://www.mbpvest.com/2016/03/28/japan-winter-wildlife-2016-tour-2-travelogue-2-podcast-516/

    Notice the white rectangle a few paragraphs into the post? That's where the Smart Podcast Player should be. If you turn off Minification in Hummingbird, you'll see the player come back to life.

    When you look under the Minification settings, you can see the Smart Podcast Players components all marked with askpat-player-plugin-.... There are three components as far as I'm aware, and the Minification checks automatically do not Minify or Combine these three scripts, but it still doesn't work. I've tried Minifying and Combining them as well, and moving them to the footer and header, and that doesn't work either.

    Anyway, please take a look at mbpvest.com, my staging server, and any help you can provide is very much appreciated.

  • Ivan Shulev

    Hey Martin ,

    I hope you are having a nice day so far!

    For whatever reason, Hummingbird was not including one of the core libraries - Underscore JS.

    I tried everything and in the end I did a dirty trick to ammend that. It is not usually recommended, but for this case it works.

    NOTE: I would strongly advise you to backup your site before implementing!

    Please add the following suggestion either as a must use plugin, your theme's functions.php file or any code snippet plugin.

    function wpmu_5433_enqueue_underscore() {
    	$uscoreurl = includes_url('js/underscore.min.js');
    	echo '<script type="text/javascript" src="'. $uscoreurl .'"></script>';
    }
    add_action( 'wp_footer', 'wpmu_5433_enqueue_underscore' );

    This is what I've already added on your testing server and you can see it at the bottom of your theme's functions.php file.

    I hope this helps and I wish you an awesome day ahead!

    Ivan

  • Martin

    Excellent! Thanks Ivan! That did the trick.

    Having added that code to a plugin on my main site, I was just able turn on Hummingbird and Minified everything, even with all plugins active.

    Ideally at some point I'd like to be able to remove that code again though. Is it possible to have a developer look at why Underscore JS was not included, or build in checks for this in Hummingbird, or something like that?

    For now, I'll leave the code in place. Thanks for your help!

  • Martin

    Hi Ivan,

    I'll mark this issue fixed, but wanted to let you know that I actually migrated my site to a new server over the last twenty four hours. The configuration is a little different. I changed from CentOS 6 to 7, but I'm still running on nginx, with the entire site over HTTPS, and I still needed your code, so it wasn't server specific as such.

    I don't know if this is important, but if your test guys aren't testing on nginx often, it might be something to look into. I'm sure you have a lot of other customers using nginx too, but I thought I'd mention it.

    Anyway, thanks again for your help.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.