Hummingbird minification, Upfront and New Blog Templates conflicts

If minification is turned on, Upfront is loading forever if a website is created through New Blog Templates: https://youtu.be/0bDIrLw6PdU
Please, take a loot at it for me at esites.pro, the access is already granted.
Thank you!

  • Sajid

    Hi diegpl,
    Hope you are doing good today :slight_smile:

    Thanks for granting support staff access. While trouble shooting, I came to know that you just enabled Hummingbird minification but did not configured it after that.

    Once you have this enabled you must configure it per site basis. Please go teach template site Dashboard -> Hummingbird and try to include/exclude some JS files from build. Because some files does not work well when combined or compress.

    As stated in the Miniffication page, you have to be careful while using this module. The best way to configure this module is including/excluding each file one by one instead of bulk. Each time you make a change here, make sure you check the frontend of your website, if something went wrong, revert that change and try a different combination.

    Once you will have these template site configured it should work with new sites too. But for start work only on one template, once you get it to work and understand the process then apply on other templates as well.

    Hope that helps! Feel free to post a reply if you need further assistance :slight_smile:

    Best Regards,
    Sajid

  • diegpl

    Well, the template is working and was always working. The only thing that does not work is when I try to access Upfront for the first time, just after to create it through New Blog Templates with automatic redirection with Gravity Forms. But this problem happens just after I turned Minification feature on. Could you please, try to make it work using the site3.esites.pro template? I will be trying on the number 2. Thank you!

  • Nastia

    Hello diegpl

    I hope you don't mind me chiming in here!

    How do I choose what will be together combined or not?

    You can deactivate or activate "combine" option for each file.

    However, you can't choose what files are combined with what. Usually the minification combines all CSS files to a CSS file, and al JS files to a one single JS file.

    It seems that is just /wp-includes/js/jquery/ui/core.min.js file that can not be combined. I will check at the others.

    Not every file can be combined and minified. You need to approach minification with caution and modifying file settings one by one.

    The only thing that does not work is when I try to access Upfront for the first time, just after to create it through New Blog Templates with automatic redirection with Gravity Forms. But this problem happens just after I turned Minification feature on.

    Once you activate the minification, all options are automatically enabled. Find the Gravity Forms files, first, try to move their position to footer. If this will not fix the issue, try to deactivate minification or the "Combine" option.

    If you need assistance with this, please grant access form WPMU DEV > Support so I can have a closer look!

    Cheers,
    Nastia

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.