[Hummingbird] My page still got caching even I had add in exclusions

http://www.greenprocapital.com/home/investor-relations-stock-price/

For this page, I had edit the annual meeting to the URL link to 2018, and it show correctly in the preview, but after I updated , the URL still link to the old 2016 one. I figure out it is the caching so I add the page in to exclusion , but this time it wont work too. Any idea how this can fix? Thanks

  • Predrag Dubajic
    • Support

    Hi Easy,

    Hope you're doing well :slight_smile:

    As I understand you have excluded annual meeting page from caching, but the thing here is that the links are actually on different page, so it's not that the annual page is cached, it's about URL not updating properly to link to correct page, is that correct?

    Would you mind allowing support access so we can have a closer look at your setup?
    To enable support access you can follow this guide here:
    https://premium.wpmudev.org/docs/getting-started/getting-support/#chapter-5

    Please respond in this ticket once access is granted.

    Best regards,
    Predrag

  • Predrag Dubajic
    • Support

    Hi Easy,

    Thanks for granting access, it seems that Hummingbird caching folder has incorrect permissions set so the plugin is unable to clear the cache from there.

    Can you try accessing your WP files via FTP or cPanel and navigate to wp-content/uploads/ folder, and check the permissions for wphb-cache folder.

    Try setting permissions of that folder to 755 and after that try clearing the cache and check if the link is properly updated.

    Let us know how it goes.

    Best regards,
    Predrag

  • Easy
    • Wordpress Newbie

    It pops up when I try to edit in the FTP

    Status: Setting permissions of '/public_html/home/wp-content/wphb-cache' to '755'
    Command: CWD /public_html/home/wp-content
    Response: 250 CWD command successful
    Command: SITE CHMOD 755 wphb-cache
    Response: 550 CHMOD 755 wphb-cache: Operation not permitted

  • Adam Czajczyk
    • Support Gorilla

    Hello Easy

    Thank you for your response.

    The error that you're getting might actually also indicate an additional problem. The "550 Operation not permitted" is not an FTP error "per se" but it comes from the server's operating system and means that you - as a logged in user (e.g. logged in via FTP) - do not have permission to perform given operation/command. So, in this case that might also prevent Hummingbird from writing to the folder.

    In this case, it means that you are not permitted to change folder permissions and that usually happens if the owner of the folder/file doesn't match the logged in user (that's a simplification but explains it in general). Example of common reasons for these are e.g. when the site was set up using some "installer" or if there's some misconfiguration of the server.

    Usually, it requires fixing webserver configuration and file/folder ownership.

    If you don't have SSH/root access to the server (or don't know how to use it) you might need to get in touch with your host support to help you sort that out - to make sure that ownerships of the files/folders are set correctly to allow you work on them (e.g. change permissions). They should be able to help you with that and there's a good chance that this alone might solve the cache problem, but if not, you would then be able to change those permissions as suggested by my colleague Predrag and that hopefully will fix the issue.

    Kind regards,
    Adam

  • Easy
    • Wordpress Newbie

    Ok, update on the issue.
    I had install autoptimize plugin, will it have conflicts with the hummingbird?
    Second, I can edit permission before, but now I can't edit anymore just like the issue I mention before above.
    My hosting support is not familiar with WordPress and they cant be helping any matter about WordPress or ftp matter.
    Any suggestion what I can do now? Thanks.

  • Easy
    • Wordpress Newbie

    Now I deactivate and delete both autoptimize and Humminbird so the website page is most update now, but without the hummingbird, the website speed is super slow in GTmetrix. If I reinstall and activate back will the caching problem back? Thanks

  • Predrag Dubajic
    • Support

    Hi Easy,

    My hosting support is not familiar with WordPress and they cant be helping any matter about WordPress or ftp matter.

    I understand that they can't help with advanced WordPress stuff but saying that they can't help with anything WP related is really surprising, especially as this is about file permissions on the server itself... I'm quite stumped by that response, to be honest.

    I had install autoptimize plugin, will it have conflicts with the hummingbird?

    These two have not been fully tested but if you don't use options that do the same thing in both plugins you should be fine.
    Example, don't enable page caching in both plugins, use it only in one of them.

    New update, I can change other folder permission to 755 in FTP but only the wphb-cache folder is not available to edit.

    Hmm, that's strange, cache folder shouldn't be any different from the other ones.
    Now that you have both HB and Autoptimize disabled can you try removing HB cache folder completely and see if the new one is created when you activate HB and if you can edit that newly created folder?

    Best regards,
    Predrag

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.