Hummingbird NGINX Issue

Installed Hummingbird. Tried to Enable GZIP and got an error(See attached screen print) and your support information had me modify the nginx.conf file. I made the suggested modifications, restarted nmginx and I am still having the same issue. Discussed issue with server provider (Media Temple) they won't touch it. Need some help.

Here is current nginx.conf text.

#user nginx;
worker_processes 1;

#error_log /var/log/nginx/error.log;
#error_log /var/log/nginx/error.log notice;
#error_log /var/log/nginx/error.log info;

#pid /var/run/nginx.pid;

include /etc/nginx/modules.conf.d/*.conf;

events {
worker_connections 1024;
}

http {
include mime.types;
default_type application/octet-stream;

#log_format main '$remote_addr - $remote_user [$time_local] "$request" '
# '$status $body_bytes_sent "$http_referer" '
# '"$http_user_agent" "$http_x_forwarded_for"';

#access_log /var/log/nginx/access.log main;

sendfile on;
#tcp_nopush on;

#keepalive_timeout 0;
keepalive_timeout 65;
#tcp_nodelay on;

#gzip on;
#gzip_disable "MSIE [1-6]\.(?!.*SV1)";

# Compression level (1-9)
gzip_comp_level 5;

# Don't compress anything under 256 bytes
gzip_min_length 256;

# Compress output of these MIME-types
gzip_types
application/atom+xml
application/javascript
application/json
application/rss+xml
application/vnd.ms-fontobject
application/x-font-ttf
application/x-javascript
application/x-web-app-manifest+json
application/xhtml+xml
application/xml
font/opentype
image/svg+xml
image/x-icon
text/css
text/plain
text/javascript
text/x-component;

# Disable gzip for bad browsers
gzip_disable "MSIE [1-6]\.(?!.*SV1)";

server_tokens off;

include /etc/nginx/conf.d/*.conf;
}

# override global parameters e.g. worker_rlimit_nofile
include /etc/nginx/*global_params;

  • Dimitris

    Hey there Zack,

    hope you're doing good today and don't mind skipping in! :slight_smile:

    As Ignacio has currently some days off, I'd like you to perform some more tests.
    The error message you're seeing suggests that the "ngx_http_gzip_module" module may not be enabled but that may not always be the case. Please double-check your server for following issues as well:

    - check that "ngx_http_gzip_module" is indeed up and running in your nginx settings

    - check if there's a Varnish cache running on server (or any other server-side caching solution) and make sure to purge/empty it

    - make sure that PHP is configured to support zlib library and that zlib output support is enabled; there's a php.ini setting for this that should be set to "on":
    zlib.output_compression = On
    In case it's set to "off" you will want to change it to "on"

    - there's also a slight chance that not all required MIME types are set to be handled by "mod_deflate" module; it should support at least "text/html", "text/javascript" and "text/css"

    You may need to contact your hosting provider for these steps but I hope it'll fix the issue.

    Kind regards,
    Dimitris