[Hummingbird] Performance check error on website

Good day,
There is an error on http://www.warthogeng.co.za - it says the following error:

The performance test didn't return any results. This probably means you're on a local website (which we can't scan) or something went wrong trying to access WPMU DEV. Try again and if this error continues to appear please open a ticket with our support heroes

Please can you assist me in resolving this?

Thank you

  • Adam Czajczyk

    Hello Garry

    I hope you're well today and thank you for your question!

    I have checked your site "from outside" and there's no redirects that could cause it, the site's responding with proper HTTP statuses. The only thing that's a bit alarming (when checking from outside) is that it seems to be powered by PHP 5.4.16 which is quite outdated. We recommend at least 5.6.x so if you could upgrade, it's worth giving a try.

    Usually, that can be changed in PHP settings in cPanel (or other server/account management panel that your host is providing). Could you please give it a go?

    It would be best to switch to 7.x but if that's not available, at least 5.6.x

    If that still doesn't help, I'll need to take a closer look at your site's setup. To let me do this, please enable support access by going to "WPMU DEV -> Support" page in your site's back-end and click on "Grant Support Access" button there, then let me know here.

    Best regards,
    Adam

  • Adam Czajczyk

    Hello Garry

    Thank you for your response and for enabling access.

    I have checked your site and it turns out that it is actually powered by PHP 7 so there's no need to change. External checks sometimes might bring false results this appears to be the case. So, that part is sorted out :slight_smile:

    I have then checked Hummingbird Performance Report and noticed that there are results displayed. Once I run Performance Test again, it completed successfully as well. I suppose then that this was a "temporary glitch" - either related to some short connectivity issues or to cache.

    I noticed that while you do have Hummingbird's Asset Optimization and Page Cache enabled, you're also using Autoptimize and Check and Enable GZIP Compression plugins. I would strongly suggest disabling them as they are redundant to Hummingbird's features and it might (especially Autoptimize) cause issues. Once disabled, go to "Hummingbird -> Dashboard" and use "Clear Cache" button there, then also use "re-check" button in Hummingbird's "Asset Optimization". It might be necessary to tweak Asset Optimization settings afterwards but you'll see that only after performing these steps. It should, however, spare you some potential troubles in future, related to these plugins conflicting with each other.

    Kind regards,
    Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.