[Hummingbird] php compatibility

Hello I have a problem with the plugin Hummingbird pro this is the eroor :
FILE: /home/arkaybev/public_html/wp-content/plugins/wp-hummingbird/core/modules/class-module-advanced.php
------------------------------------------------------------------------------------------------------------
FOUND 1 ERROR AFFECTING 1 LINE
------------------------------------------------------------------------------------------------------------
512 | ERROR | Extension 'mysql_' is deprecated since PHP 5.5 and removed since PHP 7.0; Use mysqli instead
------------------------------------------------------------------------------------------------------------
What can I do?
Thank

  • Adam Czajczyk
    • Support Gorilla

    Hello Sylvie

    I hope you're well today and thank you for your question!

    This is an output from a PHP 7 compatibility check, I believe. The Hummingbird is fully compatible with PHP 7.x but it also includes some parts of the code for providing compatibility with older versions of PHP (which are still, unfortunately, very popular). Such code is used only if it "has to be" - if a plugin is running on PHP 7 they are not in use.

    Unfortunately, tools like PHP7 compatibility check plugin and similar are not "smart" enough to be able to recognize that. They only "read code" and if they find some functions/routines that are deprecated or removed, they report that as an incompatibility, even though there's no need for that :slight_smile:

    The bottom line is, you may safely ignore this error. If you're experiencing any issues with how Hummingbird works then please describe all the details (I'd suggest opening a separate ticket for it or joining our live chat session at any time: https://premium.wpmudev.org/live-support/) and we're here 24/7 to assist you.

    Best regards,
    Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.