[Hummingbird Pro] ETmodules font not loading

Not sure if it's Hummingbird, but just in the last few days this site has stopped loading the ETModules font. The result is that there are '3' and '$' and boxes all over instead of icons, arrows etc.

However clearing the cache in Hummingbird fixes it temporarily. Could you check it out and see?

  • Sanowar Prince
    • Staff

    Hi stretchr,

    Hope you’re doing good today.

    I can see the issue on your site. After little investigation on your site, I found that your page was loading over HTTPS, but fonts were loading over HTTP. As fonts weren’t loading over HTTPS, so due to security reason they were blocked from loading.

    Also, I see you are using both Auto Optimize plugin and Hummingbird Pro together. Performing the same feature from two different plugins could conflict with each other. In your case, I am not sure which one is causing the issue.

    Could you please grant support access from WPMU DEV Dashboard plugin and let us know by replying here so that we could give a closer look. Here are the steps to grant support access. https://premium.wpmudev.org/docs/getting-started/getting-support/#chapter-5

    Best regards,

    Sanowar

  • stretchr
    • Design Lord, Child of Thor

    Hi Sanowar, I’ve granted support access.

    I installed Autoptimize as I was having issues with javascript parsing as per one of my other support tickets.

    What I’m going to try right now is disabling Autoptimize and pushing javascript to the footer.

    Cheers,

    Richard

  • Sanowar Prince
    • Staff

    Hi stretchr,

    I see you have Asset Optimization advanced mode enabled in Hummingbird. Please note, advanced mode can easily break your website if configured incorrectly.

    From Asset Optimization, I have removed the compress action for the following css files which will solve your issue.

    woocommerce-general (woocommerce.css)

    et_monarch-css (style.css)

    parent-style (style.css)

    If you have any further queries, please let us know. Have a nice day ahead.

    Best regards,

    Sanowar

  • stretchr
    • Design Lord, Child of Thor

    Hi Sanowar,

    The website was demonstrating the original issues again today. Looking at Hummingbird, the three files you set to uncompressed, were being compressed again.

    I have not touched Hummingbird since. The only thing that may have happened is a plugin update or a re-check of files. Would those files automatically compress again after running an update, or after Hummingbird re-checks assets?

    If so that’s rather a flaw. I need these files to stay uncompressed.

  • Sanowar Prince
    • Staff

    Hi stretchr,

    Hope you’re doing good today.

    On your website I can see few icons are showing properly and few aren’t. Could you please give us more information if you had any other major update or change?

    Incorrect protocol can be used if a font URL is hard coded with HTTP.

    I see the support access is expired for your website. Could you please grant it again? After you have granted the access, please let us know by replying here so that we could give a closer look.

    Best regards,

    Sanowar

  • stretchr
    • Design Lord, Child of Thor

    I’ve opened up support access again.

    There have been no changes other than updating plugins and wordpress core.

    The font URL is not hard coded with HTTP. It gets altered when compressed or combined and then cached, it may even be at the Cloudflare end of things. Because when it first occurred, if I cleared the cache on the back end, the icons came back properly for a short time.

  • Sanowar Prince
    • Staff

    Hi stretchr,

    As far as I can remember, I disabled compress action for those three files and there was no combine action enabled for them.

    When you told your website is demonstrating the original issues again then I checked the source of your website from my browser console and found that woocommerce-general (woocommerce.css) and parent-style (style.css) weren’t compressed or combined. et_monarch-css (style.css) was combined and had the issue. Now from Hummingbird Asset Optimization I can see compress action is disabled for those three files and combine action is enabled for et_monarch-css (style.css). I am not sure how combine action was activated for this file.

    Now on your website I can see all icons are showing properly. Did you clear the cache?

    From my browser console I found another CSS file et_bloom-css (style.css) which had the same issue and now from Asset Optimization I can see combine action is enabled for this file too. Now I have disabled the combine action for et_monarch-css (style.css) and et_bloom-css (style.css). It will solve the issue now.

    I can see font URL isn’t hard coded with HTTP. I already talked with our developer and he said either Cloudflare or any of your plugins is causing the issue.

    To give a closer look on this issue, we will need to run a conflict test on your website. As your current site is live with traffic, so I’d suggest you to create a staging environment, meaning a complete and exact copy of this installation into another location/folder in the same server using a separate database, so first we can see the issue there and run the conflict test then. Please make sure, Cloudflare is enabled for your staging website too.

    Replicating this issue is time consuming and if you grant support access for your staging website it could be expired before the issue is solved. So we will need WP admin login details of your staging website.

    You can send credentials by using our secure contact form: https://premium.wpmudev.org/contact/#i-have-a-different-question

    – Mark to my attention, the subject line should contain only: ATTN: Sanowar Prince

    – WordPress admin username

    – WordPress admin password

    – Website login url

    – Link back to this thread for reference

    – Any other relevant information

    Please do follow up in the ticket once you have sent the above credentials.

    Have a nice day ahead.

    Best regards,

    Sanowar

  • stretchr
    • Design Lord, Child of Thor

    Thanks Sanowar, it might take me a couple of days to get this organised.

    I didn’t clear the cache – the icons started showing properly as soon as I turned off compression that had come back on. The css file for the wishlist plugin (tinvwl) was also affected, it was combined, not compressed, and I just uncombined it to fix the problem.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.