[Hummingbird Pro] GZip Compression not working

After configuring my gzip file and talking to the hosting customer support, I haven't been able to activate gzip compression on my site. The following error appears:
Gzip is not working properly:
- Your server may not have the "deflate" module enabled (mod_deflate for Apache, ngx_http_gzip_module for NGINX).
- Contact your host. If deflate is enabled, ask why all .htaccess or nginx.conf compression rules are not being applied.

I've configured the .htaccess file manually and tried to recheck, but that did not work. Again, I spoke with customer service for my hosting platform and they were unable to help. Please advise at your earliest convenience. Thank you!

  • Nithin
    • Support Wizard

    Hi Nikhil,

    Hope you are doing good today. :slight_smile:

    Sorry to hear about the issue. Just to be sure, did your hosting provider confirm mod_deflate was enabled in the server side?

    Could you please create a file called php.ini inside the root folder, and add the following rules:

    zlib.output_compression = On

    And then check whether it works fine? The root folder is where the wp-config.php file resides.

    Please do let us know how that goes if you still have issues even after then please grant support staff access so that we could give a closer look.

    You can grant access from WPMU DEV > Support > Support Access > Grant Access, or check this manual: https://premium.wpmudev.org/docs/getting-started/getting-support/#chapter-5

    Please let us know once you enable access so that we could get this sorted. Have a nice weekend. :slight_smile:

    Kind Regards,
    Nithin

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.