[Hummingbird Pro] HB asset optimisation breaks site

I’d like to defer loading of a number of js scripts. Unfortunately, when I turn on asset optimisation in HB, it breaks the site. I’ve tried turning off all file-related settings but just turning on asset optimisation has a bad effect on the look of the site.

Any suggestions? I’ve turned on access and created a stage.