[Hummingbird Pro] help me configure humming bird

i need help with configuring humming bird. I dont want to mess up my site. Can you please remote into my computer and guide me

  • Nithin
    • Support Wizard

    Hi justlike,

    Hope you are doing good today. :slight_smile:

    Could we know regarding which aspect in the plugin side you are looking to configure? You can check our plugin documentation for more details on how to configure the plugin:

    https://premium.wpmudev.org/docs/wpmu-dev-plugins/hummingbird/

    Would highly recommend you to go through, and see whether you still have any further query.

    If you still have issues, or doubts with configuration, please do enable support access to your website so that we could give a closer look.

    You can grant access from WPMU DEV > Support > Support Access > Grant Access, or check this manual: https://premium.wpmudev.org/docs/getting-started/getting-support/#chapter-5

    Please let us know once you enable access so that we could get this sorted. Have a nice day. :slight_smile:

    Kind Regards,

    Nithin

  • Nithin
    • Support Wizard

    Hi justlike,

    As mentioned above, you can grant support access to the website via the WPMU DEV Dashboard plugin as seen in the following screenshot:

    Please do note that sharing login credentials in the forums isn't recommended as the ticket is public. Please do follow up once the support access is enabled, and let us know further about what exact query you have with setting up Hummingbird so that we could advise further.

    Kind Regards,

    Nithin

  • Nithin
    • Support Wizard

    Hi justlike,

    Thanks for enabling support access, I checked your website and I could notice Gzip has enabled also the option under Hummingbird > Advanced Tools are enabled correctly.

    Checking further the Browser Caching is only partially enabled. Could I know what’s the server your website currently running on? Is it NGINX or APACHE?

    I could notice the WPMU DEV Dashboard plugin is picking Apache, and the Hummingbird is detecting NGINX server.

    Could you please check with your hosting provider regarding this? Are you using a Plesk interface?

    Could you please share the .htaccess file located in the root directory in the next reply so that we could check further about what’s being missed with Browser Caching not getting enabled fully, under Hummingbird Pro > Caching > Browser caching.

    Please do note to share the .htaccess file in a txt file format so that the file gets uploaded in the next reply.

    Looking forward to your response, so that we could check further if needed. Have a nice day.

    Kind Regards,

    Nithin

  • justlike
    • WPMU DEV Initiate

    this is the htaccess file

    # BEGIN rlrssslReallySimpleSSL rsssl_version[3.2.3]

    <IfModule mod_rewrite.c>

    RewriteEngine on

    RewriteCond %{HTTP:X-Forwarded-Proto} !https

    RewriteRule ^(.*)$ https://%{HTTP_HOST}/$1 [R=301,L]

    </IfModule>

    # END rlrssslReallySimpleSSL

    # BEGIN WordPress

    <IfModule mod_rewrite.c>

    RewriteEngine On

    RewriteBase /

    RewriteRule ^index.php$ – [L]

    RewriteCond %{REQUEST_FILENAME} !-f

    RewriteCond %{REQUEST_FILENAME} !-d

    RewriteRule . /index.php [L]

    </IfModule>

    # END WordPress

    # BEGIN WP-HUMMINGBIRD-CACHING

    <IfModule mod_expires.c>

    ExpiresActive On

    ExpiresDefault A0

    <FilesMatch “.(txt|xml|js)$”>

    ExpiresDefault A691200

    </FilesMatch>

    <FilesMatch “.(css)$”>

    ExpiresDefault A691200

    </FilesMatch>

    <FilesMatch “.(flv|ico|pdf|avi|mov|ppt|doc|mp3|wmv|wav|mp4|m4v|ogg|webm|aac|eot|ttf|otf|woff|svg)$”>

    ExpiresDefault A691200

    </FilesMatch>

    <FilesMatch “.(jpg|jpeg|png|gif|swf|webp)$”>

    ExpiresDefault A691200

    </FilesMatch>

    </IfModule>

    <IfModule mod_headers.c>

    <FilesMatch “.(txt|xml|js)$”>

    Header set Cache-Control “max-age=691200”

    </FilesMatch>

    <FilesMatch “.(css)$”>

    Header set Cache-Control “max-age=691200”

    </FilesMatch>

    <FilesMatch “.(flv|ico|pdf|avi|mov|ppt|doc|mp3|wmv|wav|mp4|m4v|ogg|webm|aac|eot|ttf|otf|woff|svg)$”>

    Header set Cache-Control “max-age=691200”

    </FilesMatch>

    <FilesMatch “.(jpg|jpeg|png|gif|swf|webp)$”>

    Header set Cache-Control “max-age=691200”

    </FilesMatch>

    </IfModule>

    # END WP-HUMMINGBIRD-CACHING

  • Nithin
    • Support Wizard

    Hi justlike,

    Thanks for sharing the htaccess file. htaccess files are part of the Apache server the content shared do look fine. It sounds like the website is running on Apache with NGINX as a reverse proxy.

    However, to double-check regarding that aspect, could you please share your website, and cPanel credentials so that we could check further regarding this?

    You can send credentials by using our secure contact form: https://premium.wpmudev.org/contact/#i-have-a-different-question

    – To Mark to my attention, the subject line should contain only: ATTN: Nithin Ramdas

    -WordPress admin username

    -WordPress admin password

    -login URL

    -cPanel credentials (host/username/password)

    -link back to this thread for reference

    -any other relevant URLs

    Please do follow up on the ticket once you have sent the above credentials. Have a nice day. :slight_smile:

    Kind Regards,

    Nithin

  • Nithin
    • Support Wizard

    Hi justlike,

    Thanks for sharing the login credentials, on giving a closer look, it seems more like the server default value for browser caching isn’t getting overwritten by the changes done by Hummingbird.

    It always stays the same, even tried adding the following code in htaccess to see how it goes but still the same issue:

    ExpiresActive On
    ExpiresByType image/jpg "access plus 1 year"
    ExpiresByType image/jpeg "access plus 1 year"
    ExpiresByType image/gif "access plus 1 year"
    ExpiresByType image/png "access plus 1 year"
    ExpiresByType text/css "access plus 1 month"
    ExpiresByType application/pdf "access plus 1 month"
    ExpiresByType text/x-javascript "access plus 1 month"
    ExpiresByType application/x-shockwave-flash "access plus 1 month"
    ExpiresByType image/x-icon "access plus 1 year"
    ExpiresDefault "access plus 2 days"

    But still the same issue. I’m afraid, this is more specific to the server not allowing to override the changes done via the htaccess file.

    Could you please get in touch with your hosting provider, and check whether mod_expires module is enabled? If yes, please check what’s being missed with browser cache code added in .htaccess file not able to work with the current setup?

    Please do let us know what your host has to say regarding this so that we could check further if needed.

    why does the plugin say there are 118 issues found on my site?

    From the screenshot what you have shared, it’s 118 Assets, not Issue. Assets are CSS and JS files which are loaded in your website. These CSS and JS files would be part of your theme and the active plugins.

    Please check this doc to know more about Asset Optimization:

    https://premium.wpmudev.org/docs/wpmu-dev-plugins/hummingbird/#asset-optimization

    Kind Regards,

    Nithin

  • Nithin
    • Support Wizard

    Hi justlike,

    Thanks for sharing the links that were helpful. The issue was related to the default setting enabled in the cPanel side, under "Cache Manager" option as mentioned in here:

    https://www.inmotionhosting.com/support/website/cpanel/nginx-plugin-for-cpanel

    Once I selected your website domain, and under "Options" tab, the option for "Accelerate static content" was enabled, which was causing the issue with browser cache not working via the Hummingbird side.

    I went ahead, and disabled the "Accelerate static content" settings:

    Once done cleared the cache, and re-checked the Browser Caching status, and now it's working fine.

    I hope it's clear now. Please do check, and let us know if you have any further query. Have a great weekend ahead. :slight_smile:

    Best Regards,

    Nithin

  • Nithin
    • Support Wizard

    Hi justlike,

    I did a google speed test and the result said, Your mobile page speed is 6.9 seconds on a 4G

    connection. The reason I am interested in hummingbird is this, I want my site to load in less than 2 seconds.ow can you help?

    I checked your website, and there were a couple of improvements that could have further performed. Like Smush CDN, Page cache, Asset Optimization etc

    I have already enabled Smush CDN, under Smush Pro > Smush CDN, and Lazyloading feature under Smush Pro > Lazyload which should help with serving the images via the Smush CDN, so it would load much faster, and with less load to the website. Would recommend you to bulk smush any pending images so that it would get optimized too.

    One of the main aspects with slow load website is server resources, and cache. At the moment when I checked your website, it seems like Page cache is disabled in your website. And I could notice you have WP Super Cache plugin enabled, but checking the settings the Page cache is disabled even in the WP Super Cache plugin too.

    You'll have to either enable Cache via the WP Super Cache plugin, or delete it, and make use of Page Caching feature via Hummingbird plugin, under Hummingbird Pro > Caching > Page Caching section, so that the website would load much faster.

    Other aspects that could be improved would be Asset Optimization by switching to "Advanced Mode" in Hummingbird side as shown in the following screenshot, under Hummingbird > Asset Optimization

    Once switched to advanced mode, the plugin gives more control on how each file could be optimized further. Asset optimization helps with improving the render-blocking score shown in Google Page speed results.

    However, please do note that there isn't any way to get a full score regarding Asset Optimization, as it entirely depends upon the theme, and how it honours the minification settings. What could be done is to improve the existing score, which would require a trial and error method.

    You can check the following article on how to move forward with this:

    https://premium.wpmudev.org/blog/eliminate-render-blocking-issues-hummingbird/

    https://premium.wpmudev.org/docs/wpmu-dev-plugins/hummingbird/#chapter-4

    Please do let us know how that goes so that we could check further if needed.

    Kind Regards,

    Nithin

  • Nithin
    • Support Wizard

    Hi justlike,

    I have disabled the WP Super Cache plugin and enabled Hummingbird cache feature in Hummingbird side.

    Smush CDN and Lazyload features are currently enabled, and all the images do look optimized at the moment.

    Could I know what exact confusion you have regarding tweaking up the website? I'm afraid, setting up and configuring Asset Optimization is outside our support scope.

    However, as an exception, I have enabled Advanced mode as mentioned in my previous reply, and have optimized, and further tweaked the files, under Hummingbird > Asset Optimization page as mentioned in the following links:

    https://premium.wpmudev.org/blog/eliminate-render-blocking-issues-hummingbird/

    https://premium.wpmudev.org/docs/wpmu-dev-plugins/hummingbird/#chapter-4

    The Hummingbird Performance score has improved from 56 to 89 once done.

    The page-load has improved, and the load time average is around 2.5 seconds.

    However, could notice the server does take time to establish an initial connection if that could be improved the page load speed could be improved much better. Would recommend you to check with your hosting provider regarding whether there is any further improvement in the server-side that could be done to help reduce the load time within the server-side too.

    Please do check, and let us know what your hosting provider has to say regarding page load speed too.

    Kind Regards,

    Nithin

  • justlike
    • WPMU DEV Initiate

    also on my admin dashboard, JETPACK posted this “Improve your site’s performance and speed

    Activate Jetpack’s site accelerator to load pages faster, optimize your images, and serve your images and static files (like CSS and JavaScript) from our global network of servers.” Does hummingbird already have this feature? its seems the reason my site doesn’t load in less than 2seconds is because of css and javascript.

  • Nithin
    • Support Wizard

    Hi justlike,

    how can I minify javascript to speed up site?

    The website loads in 2.3 to 2.7 seconds at the moment. What aspect are you looking to speed up? Any specific page you are noticing the issue?

    Asset Optimization feature is what that minifies Javascript and CSS in Hummingbird. That’s already configured as mentioned in my previous reply, under Hummingbird Pro > Asset Optimization page.

    When testing the site via Pingdom ie via the following link:

    https://tools.pingdom.com/

    The page takes around 2 seconds to load. The general rule of the thumb to optimize CSS, and JS files via Asset Optimization would be to move the files to the footer ie for example:

    1) Go to the 1st file listed in the Asset Optimization page, enable “Compression” option for the 1st file,

    2) Load the frontend, and check whether the homepage design or layout breaks

    3) If not, you can enable the “Combine” option, and then check the homepage, and see whether the layout breaks.

    4) If the layout breaks this time, you’ll have to revert the “Combine” option Save the changes and move on with the next step which is “Move to footer”, and check whether it breaks the style, if yes, revert if needed. Then carry the step 1 again for the next file, until you get an optimised result.

    The only way to find out which exact file needs to be moved to footer etc is only via Trial, and error method. As this is something which is entirely depended upon your theme and will vary from one theme to another.

    I have already made the above changes regarding Asset optimization as stated in the previous reply, if you are looking to tweak further then you’ll have to follow the above steps to move forward.

    The Pingdom results do point out the server takes time to establish an initial connection:

    https://tools.pingdom.com/#5b1a762b7a000000

    What Hummingbird does is server application-level fix, if the server is slow in general no amount of fixes done in the plugin side would help much. Did you mention the results noticed in Pingdom with your hosting provider regarding that?

    Activate Jetpack’s site accelerator to load pages faster, optimize your images, and serve your images and static files (like CSS and JavaScript) from our global network of servers.” Does hummingbird already have this feature? its seems the reason my site doesn’t load in less than 2seconds is because of css and javascript.

    That would be Asset Optimization in Hummingbird. It would be better to disable the Site accelerator settings in JetPack to avoid conflicts as they serve similar action.

    Please do let us know if you have any further query.

    Kind Regards,

    Nithin

  • Nithin
    • Support Wizard

    Hi justlike ,

    Could you please enable support access to your website so that I could check what all settings have been configured in the dashboard side?

    You can grant access from WPMU DEV > Support > Support Access > Grant Access, or check this manual: https://premium.wpmudev.org/docs/getting-started/getting-support/#chapter-5

    Please let us know once you enable access so that we could check further.

    Kind Regards,
    Nithin

  • Nithin
    • Support Wizard

    Hi justlike ,

    I tested Asset Optimization settings in Hummingbird plugin, and it’s configured at its optimal setting at the moment. I further checked the websites server load via Pingdom:
    https://tools.pingdom.com/#5b5539178ec00000

    And all the files and assets are loading within seconds without any issue. I’m afraid, the primary issue with slow load speed still points to the server-side. All the settings within the Hummingbird side are configured correctly, and optimal.

    As stated in my previous reply:
    https://premium.wpmudev.org/forums/topic/hummingbird-pro-help-me-configure-humming-bird/#post-3667268

    What Hummingbird does is application-level fixes, if the server is slow in general no amount of fixes in the plugin side would help much due to the server. I’m afraid, this is something you’ll have to bring into your hosting provider’s attention, and see what advancement they could perform on the host side to improve the slow speed.

    Please do let us know how that goes.

    Regards,
    Nithin

  • justlike
    • WPMU DEV Initiate

    I checked the site speed test on google and GTmetrix and I scored F for Defer parsing of JavaScript.
    https://gtmetrix.com/reports/justlikegod.org/GnMlNDCx . loading time was like 5 seconds which is really slow. what can your apps do to fix the issue with Defer parsing of JavaScript? I am paying almost $50 every month and I’m not happy with my site speed. its not server-side when its issue with “Defer parsing of JavaScript.”

  • Nithin
    • Support Wizard

    Hi justlike ,

    I do understand you, however, please do note that Google Page Speed results are correlated to page load but these aren’t what’s primarily causing the website to load slowly in your website, as pointed in my previous reply when checking the links listed in Defer Parsing Javascript via Pingdom results, they were loading within seconds. It was the server which was taking more time than expected causing the website to load slow.

    However, when I check your website at the moment, it seems like you have enabled Jetpack CDN Most of the URLs listed under “Defer parsing Javascript” is pointing to JetPack URL. Enabling similar CDN features via different plugins can cause conflicts, and would give uneven results with load, and page speed score:

    https://c0.wp.com/c/5.2.3/wp-includes/js/jquery/jquery.js
    https://c0.wp.com/c/5.2.3/wp-includes/js/plupload/moxie.min.js

    So I wasn’t able to compare the given Gtmetrix, and Page speed score correctly due to that. It seems like support access to your website isn’t enabled, so couldn’t check the settings in the dashboard side.

    You should find the option to disable JetPack CDN settings, under JetPack > Settings > Performance in your website dashboard by unchecking the settings enabled for “Performance & speed”.

    Once done, please clear the cache, and go to Hummingbird Pro > Asset Optimization, and click “Re-Check” button to compose the Asset Optimization list.

    Please let us know how that goes so that we can re-run a new GTmetrix, Page Speed score etc to compare the score and provide further assessment. Please do make sure to enable support access once you reply.

    Regards,
    Nithin

  • Nithin
    • Support Wizard

    Hi justlike ,

    I have made the changes as mentioned in the previous reply, and now the “Defer parsing of Javascript” has improved to grade 69 as shown in the following screenshot:

    The rest of the files listed are either 3party CDN links or already optimized asset where there isn’t any scope of improvements.

    I could notice the testimonial isn’t loading any images in the homepage section, and the image links seem to be broken. When I check the dashboard ie under Media > Library, I don’t see the images present on the dashboard side too.

    Please do make sure to update the images, as broken image links can cause the website to slow down.

    I have made the changes in the Hummingbirds Asset Optimization which should improve the overall website performance. However, please do note that making changes via Asset Optimization is outside our scope of support, the tweaks what’s currently done from our side is an exception.

    If you are looking to tweak these settings further it’s something you’ll have to perform by yourself on your side. You can check these links for more info:
    https://premium.wpmudev.org/docs/wpmu-dev-plugins/hummingbird/
    https://premium.wpmudev.org/blog/eliminate-render-blocking-issues-hummingbird/

    Regards,
    Nithin

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.