[Hummingbird Pro] Hummingbird and other apps from wpmudev not working on my wp site

Hummingbird pro and Smush are are not working. Hummingbird keeps telling me to enable something but won't say what. If you run a speed test on my site you will see what the issues are. My last speed test ihere, it was suggested i get both the apps I already have.

  • Nithin
    • Support Wizard

    Hi Duane,

    Hummingbird keeps telling me to enable something but won’t say what. If

    I’m afraid, it isn’t exactly clear what exact issues you are facing in the dashboard side. Could you please share screenshots regarding this, so that we could have a better idea?

    If you run a speed test on my site you will see what the issues are. My last speed test ihere, it was suggested i get both the apps I already have.

    I could notice the current score is 49 in Google Page Speed. Would like to see what all settings are enabled in the dashboard side for the mentioned plugins so that we could check what further improvements could be done.

    Could you please grant support staff access so that we could give a closer look. You can grant access from WPMU DEV > Support > Support Access > Grant Access, or check this manual: https://premium.wpmudev.org/docs/getting-started/getting-support/#chapter-5

    Please let us know once you enable access so that we could get this sorted. Have a nice weekend. :slight_smile:

    Kind Regards,

    Nithin

  • DAV
    • New Recruit

    “GZip compression is currently active for 2/3 types. We’ve detected you have Privacy Mode active which prevents us from accurately detecting whether HTML compression is active or not. You can re-check this when you’ve disabled Privacy Mode.”

    Where is privacy mode? I have no idea where to disable it.

  • Kris
    • Support

    Hi DAV

    I log in to your site and I see WPMU DEV Dashboard installed and active, it also display correct in left menu on top

    If you still cannot see it, can you disable and enable plugin again and see does that help?

    GZip compression is currently active for 2/3 types. We've detected you have Privacy Mode active which prevents us from accurately detecting whether HTML compression is active or not. You can re-check this when you've disabled Privacy Mode.

    I checked the site and I see that it show that gzip compression is enabled for two MIME types – Javascript and CSS – but it shows it as "inactive" only for HTML.

    The "Privacy Mode" in this case means that the site responds to the request with HTTP 401 status. It's possible the "mod_deflate" module are not configured to handle with all required MIME types, so, can you please contact your host provider to double check if it supports "text/HTML".

    I also ping your site on outside sites and result is that gzip on server side is on enabled.

    I notice you also use W3 Total Cache on page which for sure conflict with Hummingbird, so Page and Browser caching cannot work correct.

    I recommend to choose which plugin on site you want to use, using more that one cache plugin could affect site speed and incorrect scores as well.

    As for you Hummingbird score I will also recommend to disable W3 Total Cache and focus on Hummingbird -> Asset Optimization which from what I see have enabled advanced mode. However this tool is not used at all.

    Here you can find full guide for Asset Optimization:

    https://premium.wpmudev.org/docs/wpmu-dev-plugins/hummingbird/#asset-optimization

    Kind Regards,

    Kris

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.