[Hummingbird Pro] Hummingbird Asset Optimization Breaks Site

Hi there,

I'm trying to activate the asset optimizaion tool, but it keeps messing up my webistes navigation. Is there anyway I can get some assistance in figuring this out?

  • Nithin
    • Support Wizard

    Hi Doug Davis,

    We could tell better regarding this once the support access to the dashboard is enabled. Could you please grant support staff access so that we could give a closer look.

    You can grant access from WPMU DEV > Support > Support Access > Grant Access, or check this manual: https://premium.wpmudev.org/docs/getting-started/getting-support/#chapter-5

    Please let us know once you enable access so that we could get this sorted. Have a nice weekend. :slight_smile:

    Kind Regards,

    Nithin

  • Nithin
    • Support Wizard

    Hi Doug Davis,

    Thanks for enabling support access, I gave a closer look and could notice the issue with menu breaking in 2 lines once Asset Optimization is enabled.

    On further troubleshooting, the issue is more related to the themes inline CSS(reda-google-fonts-inline-css) getting overridden by the app.css file in the theme side when Asset Optimization is enabled.

    Could I know whether you are aware of adding the following CSS in your website, or was it something generated by the theme? Since it’s a 3rd party theme making sure whether I’m not missing any specific settings.

    body{font-family:'Lato',Arial, Helvetica, sans-serif;font-weight:400;font-style:normal;}h1,h2,h3,h4,h5,h6,blockquote, body .widget_recent_entries a, .widget_recent_comments ul li > a, .mosaic-info .mosaic-link{font-family:'Playfair Display',Arial, Helvetica, sans-serif;font-weight:400;font-style:normal;letter-spacing:0px;}.main-navigation .nav-items a, .fixed-nav ul li a{font-family:'Lato',Arial, Helvetica, sans-serif;font-weight:700;font-style:normal;letter-spacing:1px;font-size:12px;}.btn{font-family:'Playfair Display',Arial, Helvetica, sans-serif;font-weight:500;font-style:normal;}

    Please do advise if the above is added via any specific theme settings or manually added so that we could double-check whether there are any workarounds regarding how the CSS is loaded when Asset Optimization is enabled.

    If it’s part of theme settings, and if you are aware of the settings please do point out where exactly it’s configured in the theme side so that we could see what could be done in such use case too.

    Kind Regards,

    Nithin

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.