[Hummingbird Pro] Hummingbird caching error keeps repeating

Hi there,

Yesterday, I spoke with Nastia on Live Chat regarding an issue on a clients multisite, lunchsites.com, where the ste went down. The issue turned out to be a conflict in the Hummingbird cache. She talked us through getting the site back up and thought that the issue was resolved. Unfortunately, the site went down with the same error, again, this morning.

The same solution got the site back up (changing the 'WP_CACHE' setting in the wp-config file to 'false' but, clearly, the root casue hasn't been resolved.

I've granted Support Access to you to take a look. Just let me know if you need anything else.

Regards,

Steve

  • Adam Czajczyk
    • Support Gorilla

    Hi Steve – Just Think BiG

    I hope you’re well today!

    It seems that the Page Caching is currently active again on site so if the site goes down again, please make the change in “wp-config.php” file that Nastia suggested and keep it set to “false” to keep cache disabled.

    Meanwhile, I’ve passed the error log (from the chat) to our developers asking them for advice on what might be causing that so we could at least know what direction to follow with further troubleshooting.

    It would also be helpful if you could provide me with full access credentials to the site in case our developers would need to take a closer look. Could you do this, please?

    Note: Don’t leave your login details in this ticket.

    Instead, you can send me your details using our contact form https://premium.wpmudev.org/contact/#i-have-a-different-question and the template below:

    Subject: “Attn: Adam Czajczyk

    – Site login URL

    – WordPress admin username

    – WordPress admin password

    – FTP credentials (host/username/password)

    – cPanel credentials (host/username/password)

    – Folder path to site in question

    – Link back to this thread for reference

    – Any other relevant urls/info

    Best regards,

    Adam

  • Steve - Just Think BiG
    • Thinking Bigger

    Hi Adam,

    Actually, the cache is set to ‘false’ in the wp-config file but Hummingbird still shows it as enabled. Not sure whether that’s related to the issue or not?

    I’ve contacted my client for ftp credentials as he hosts the site himself. Once I have them, I’ll add those and the WP login credentials in the notes for support access. Seems simpler and more secure that way.

    Of course, I’ll let you know when they’ve been added.

    Regards,

    Steve

  • Tho Bui
    • Staff

    Hi Steve – Just Think BiG,

    I confirmed the issue, I will move it to our dev to fix this, hope this can fix on the new version. In this case, you can avoid the error by going to HMB-> Caching->Page Caching and disable Enable debug log.

    Or if you enabled the debug log, please keep on the wp-content/wphb-logs/page-caching-log.php file, don’t try to delete this file. If this file doesn’t exist, you can create a new one with content <?php die(); ?>.

    Kind Regards,

    Tho Bui

  • Steve - Just Think BiG
    • Thinking Bigger

    Hi Tho Bui,

    Thanks for the update. I’ve advised my client.

    Unfortunately, I see that the Browser Caching isn’t working and I’m wondering whether this is part of the same issue. Perhaps you could take a look for me please?

    The error message is as follows;

    Browser Caching is not working properly:

    – Your server may not have the “expires” module enabled (mod_expires for Apache, ngx_http_headers_module for NGINX)

    – Another plugin may be interfering with the configuration

    If re-checking and restarting does not resolve, please check with your host or open a support ticket with us.

    I’ve granted support access, again.

    regards,

    Steve

  • Tho Bui
    • Staff

    Hello Steve – Just Think BiG,

    Have you contacted your hosting provider to check if mod_expires module is enabled on your server (if that is nginx it will be ngx_http_headers_module)?

    If they confirm that it is enabled, please check if manually adding caching rules to .htaccess file will resolve the issue. Those rules can be found under the link “Want to do manually?”

    Let us know if this helps.

    Kind regards,

    Tho Bui

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.