[Hummingbird Pro] Hummingbird optimization

I'm trying to speed up my mobile times and it appears that Hummingbird is adding some render-blocking resources:

https://timflemingwebdesign.com/wp-content/plugins/wp-hummingbird/admin/assets/css/critical.css?ver=2.0.0.1 591 B 480 ms

https://timflemingwebdesign.com/wp-content/uploads/hummingbird-assets/286f220d3d4c4cbb8885604266b01f7b.css 11 KB 1230 ms

https://timflemingwebdesign.com/wp-content/uploads/hummingbird-assets/e0d8550562bd98ddb4eb8124fcfe5e1e.css 65.2 KB 1830 ms

https://timflemingwebdesign.com/wp-content/uploads/hummingbird-assets/0572bc3fd71c32ba6ac53517c7cadb1a.js 32.9 KB 1230 ms

How do I fix? I am hosted by WPEngine and they have their own caching schemes. Any advice on settings with WPEngine?

  • Nithin
    • Support Wizard

    Hi Tim,

    Hope you are doing good today. :slight_smile:

    I checked your website, and I don't see the critical.css file listed in the source code as mentioned above. Could notice the rest of the mentioned files as you have stated. These files are part of the Asset Optimization feature in Hummingbird.

    What Asset Optimization feature does is minify, compress, and combine all the CSS, and JS into a single file, so that the number of files listed for the render-blocking issue could be reduced. For example:

    siteURL.com/wp-content/uploads/hummingbird-assets/0572bc3fd71c32ba6ac53517c7cadb1a.js
    siteURL.com/wp-content/uploads/hummingbird-assets/0572bc3fd71c32ba6ac53517c7cadb1a.css

    etc`

    So, for example, if there are 10 CSS files loaded by your website, Hummingbird will try to reduce the number of files and tries to load all the assets into a single file as above.

    However loading all the CSS, and JS assets into a single file entirely depend upon your theme, and how it honours Asset Optimization. In most cases, Hummingbird Pro will try to split the CSS, and JS into multiple such CSS, and JS files, that's what you are noticing as listed:

    https://timflemingwebdesign.com/wp-content/plugins/wp-hummingbird/admin/assets/css/critical.css?ver=2.0.0.1 591 B	480 ms
    
    https://timflemingwebdesign.com/wp-content/uploads/hummingbird-assets/286f220d3d4c4cbb8885604266b01f7b.css 11 KB	1230 ms
    
    https://timflemingwebdesign.com/wp-content/uploads/hummingbird-assets/e0d8550562bd98ddb4eb8124fcfe5e1e.css 65.2 KB	1830 ms
    
    https://timflemingwebdesign.com/wp-content/uploads/hummingbird-assets/0572bc3fd71c32ba6ac53517c7cadb1a.js 32.9 KB	1230 ms

    If you try to load these files via the browser, you should notice all the CSS, and JS are combined and compressed together.

    This would be how minification would work, if you could enable support access, I could check the dashboard to see whether there are any further improvements regarding Asset Optimization that could be done further.

    I am hosted by WPEngine and they have their own caching schemes. Any advice on settings with WPEngine?

    It's better to use cache offered by the hosting provider. You can disable the Hummingbird Page Cache in that case, and use the cache offered by the Host. Enabling the same cache features in the plugin, and the host side could lead to conflicts.

    You can grant access from WPMU DEV > Support > Support Access > Grant Access, or check this manual: https://premium.wpmudev.org/docs/getting-started/getting-support/#chapter-5

    Please let us know once you enable access so that we could get this sorted. Have a nice day. :slight_smile:

    Kind Regards,
    Nithin

  • Nithin
    • Support Wizard

    Hi Tim,

    Hope you are doing good today. :slight_smile:

    I can see the critical.css file using SFTP.
    There's nothing in it. Safe to delete?

    As stated before, I checked your live website again, and I don't see the critical.css file being called or listed when the homepage loads. I guess the Hummingbirds Performance Report is where you are noticing it, right?

    I doubt checked by running the website in Google Page Speed, and the new scan results didn't list any such files.

    Then re-ran the Hummingbird Performance results, and now the score went up from 91 to 98, and there aren't any such file called critical.css being listed in the results too.

    Deleting plugin files isn't something which's recommended. Since there isn't any instance where I could notice critical.css file being loaded, what would have noticed would be an old result which seems to be fixed now.

    I could notice Asset Optimizations are already optimized to its optimal settings, and a score of 98 is really a great score, which should be good.

    Please do let us know if you still have any further query. Have a great day ahead.

    Kind Regards,
    Nithin

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.