[Hummingbird Pro] Performance test timing out

I was on chat support with this issue but got disconnected and it's still not totally solved. I was having issues with the performance test on hummingbird. Right now when I run a new test on my site the screen goes white. I then have to refresh and the test continues. Better than when it would just freeze at 99% before, but still leaves me thinking not everything is running correctly.

  • Neel Gajjar
    • Staff

    Hello Joey,
    how are you doing today?

    Sorry to hear that you are having an issue running performance test in Hummingbird Pro plugin.
    Performance test in Hummingbird Pro uses Google PageSpeed Insights API for testing the page and displaying the result.

    I did test your website directly at Google PageSpeed Insights directly it took a while but did manage to get the result.

    Can you try running performance test from The Hub here :
    https://premium.wpmudev.org/hub/my-websites/

    And also could you please grant us temporary support access to your website so we can have a better look at your setup and settings? You can grant us access via WPMUDEV Dashboard plugin, there's no need to share credentials. Here's our detailed documentation page about it:
    https://premium.wpmudev.org/docs/getting-started/getting-support/#chapter-5

    Don't forget to let us know once it will be enabled.

    I'm looking forward to hearing from you and resolving this issue as soon as possible.

    Kind Regards,
    Neel Gajjar

  • Neel Gajjar
    • Staff

    Hello Joey,

    Thank you for proving your backend access.

    I can see there are many plugins installed on your site and few of them are related to caching.
    Out of which WP Super Cache & Autoptimize plugin does a similar job as Hummingbird Pro.
    There might be a plugin conflict due to which Hummingbird Pro is not able to do a performance test from the WordPress Admin panel.

    It's not recommended to use two plugins which do a similar job on one site.
    All plugins which are not in use or does the similar job should be deactivated and deleted, it increases the performance of the website and there is very less chance any plugin conflict to occur.

    Please take FULL BACKUP before deactivating any plugins and changing any settings.

    Could you please deactivate all the plugins which do a similar job as Hummingbird Pro such as Autoptimize, Wp Fastest Cache, JetPack, etc and then try to check the Performance Test?

    If still performance test in Hummingbird doesn't work. Could you do a full Conflict test?
    Please follow these steps :
    First, create a recent full backup of your site in case you lose any settings during the test and have to restore to a previous working state.
    Then deactivate all plugins and MU-plugins apart from WPMUDEV Dashboard and Hummingbird Pro activate a default theme like TwentySeventeen, clear all caches and check again if the issue is still there.

    Please check your file permissions and .htaccess once.
    If not, it means that something is conflicting, so start activating the remaining plugins and theme, one by one this time, checking every time for the reported issue, until you reproduce the issue, thus finding the conflicted combination.

    If this is a live website with traffic, I'd rather advise creating a staging environment, meaning a complete and exact copy of this installation into another location/folder in the same server, using a separate database, and perform the test in there instead without worrying about the live site.
    Reference: https://premium.wpmudev.org/docs/getting-started/getting-support/#chapter-2

    I'm looking forward to hearing from you and resolving this issue as soon as possible.

    Kind Regards,
    Neel Gajjar

  • Joey
    • New Recruit

    I only turned Autoptimize and Wp Fastest Cache back on after this issue started because my page speed score was 10 and at least with them it was 30. But they were off when the issue began.

    I'll try again with jetpack off

  • Joey
    • New Recruit

    Moved everything to staging, switched theme to 2019 and turned off all the plugins (I can't turn off MU right now) and still running into the same issue. Performance test just freezes on blank white page.

    What am I checking for with file permissions and htaccess? And am I just clearing the cache in Hummingbird or some other way?

  • Neel Gajjar
    • Staff

    Hello,

    Can you please provide us access to your staging website. We need to do some troubleshooting to find the exact cause of it. We might disable a few plugins, switch themes to troubleshoot the issue.

    Please send your staging credentials and other relevant information.

    As this is a public forum, you should send us your details through our safe contact form
    https://premium.wpmudev.org/contact/#i-have-a-different-question

    using this template:

    Subject: "Attn: NEEL GAJJAR"
    - WordPress admin (login URL/username/password)
    - (S)FTP credentials for file access (host/username/password/path of the website in question)
    - server panel/cPanel/Plesk/phpMyAdmin credentials for database access (login
    URL/username/password)
    - link back to this thread for reference (e.g.
    https://premium.wpmudev.org/forums/topic/example-topic)
    - any other relevant urls

    Keep in mind the subject line as ensures that it gets assigned to me.

    Please reply back over here, when you are done sending the email.
    I'm looking forward to hearing from you and resolving this issue as soon as possible.

    Kind Regards,
    Neel Gajjar

  • Neel Gajjar
    • Staff

    Hello Joey,
    how are you doing today?

    Thank you for proving the credentials for your staging website.
    So I did some testing and made few changes in your staging site.
    Now the performance test is working without any errors in your staging site.
    Could you please check once?

    If it works without any errors on the staging site, please activate all the necessary plugins and theme one by one.
    Please don't activate any similar functionality plugins as there is always a chance to have a conflict.

    If everything goes well under staging site these are changes I made in the staging site which helped to solve the issue.
    I did 3 changes as follows :
    Please a Full Backup before making any of the changes into your live site.

    1. I went ahead and increased the memory limit. This can be done by adding below of code to wp-config.php file.

    define( 'WP_MEMORY_LIMIT', '256M' );

    You need to paste this code in wp-config.php file just before the line that says ‘That’s all, stop editing! Happy blogging.’

    Please download the wp-config.php file first before updating it so you have a backup.

    Run a Performance test, if it is working then no need to do the below 2 changes.

    2. I replace the existing .htaccess file with new regenerated file.
    To regenerate it visit Wp-Admin > Settings > Permalinks, Click save changes.

    I would you suggest you to rather than deleting the above file rename it to .htaccess-old

    3. Please only try this step if the above two steps don't solve the issue.
    I went ahead and reset the Hummingbird plugin's settings.
    Wp-Admin > Hummingbird Pro > Settings > Click on Reset Settings.

    Before resetting please take a screenshot or note down the asset optimization you made in your live sites.
    Reset will also remove your CloudFlare configuration. This might be also causing some conflict.

    Hope this helps.

    I'm looking forward to hearing from you and resolving this issue as soon as possible.

    Kind Regards,
    Neel Gajjar

  • Joey
    • New Recruit

    Hey Neel - so I had to do all three steps but it finally worked!

    One thing - on the staging I get a score of 99.

    On the live site, with the exact same plugin and theme configuration, I get a score of 30. Why is that?

  • Neel Gajjar
    • Staff

    Hello Joey,

    I had to do all three steps but it finally worked!

    Glad it worked out.

    One thing - on the staging I get a score of 99.

    There was some caching issue. I think after activating all the plugins and theme you didn't clear the cache.
    As a logged in user I was able to see the new Divi theme which you activated. But when I log-out or check the site on a different browser it was still showing twenty-nineteen theme.

    So while running a Performance test from Hummingbird PageSpeed was still getting the cached stagging site.

    After clearing the cache now it shows the score similar to what you get in the live website.

    Please see the screenshot.

    Hope this helps.

    Kind Regards,
    Neel Gajjar

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.