[Hummingbird Pro] Photos not showing up in Subscribe By Email digest

I believe this is a caching issue caused either by hummingbird or smush, and that changing my configuration of one of these plugins will fix it. The problem has happened before, whereby when the plugins are updated some exclusions are lost things end up getting smushed or cached that shouldn’t be. All that said, maybe the cause of the problem is entirely something else.
What is happening is that the featured images of posts aren’t showing up in the digest that is sent out to members — they are getting a digest that includes no images, except for the banner in the header. None of the featured images are presented with the summary of the relevant blog post.
Could you please walk me through the process of figuring out how to get the images to appear in the digest. They use to, but stopped at some point after one of the plugin updates.

  • Pawel
    • Staff

    Hello xbladerunner !

    Our apologies for the issues you’ve encountered in this case! Let’s see what we can do to fix that.

    The issue you’ve described doesn’t seem to be connected to caching or Smush actually. If you’re experiencing issues with those plugins, please open a separate ticket so we can check that out for you.

    On the other hand, I think it’s because of a theme update that has removed some email templates you might have had previously. Please check the Subscriptions >> Settings page – there are some instructions at the top on how to copy and override default email templates by placing and editing the template files in your theme’s directory. I’ve created an SSH account on the host to check that, and in fact, I’m not seeing any templates from SBE in any of the installed themes.

    Unfortunately WordPress, when it updates themes, removes the old folder first and unpacks the new one, so all changes are lost. If you have a backup from some time ago, you may be able to recover your old SBE templates from there. If not, creating new ones as explained on the Subscriptions >> Settings page will allow you to include the featured images in the emails again. You can use the sbe_show_featured_image() function to do that and wrap it around in some HTML for styling. The function will output an tag for the image.

    It’s just a first thought about the issue though. I may be wrong saying the above, but that’s as far as I was able to test that without Support Access. If you require further checking of the issue, please enable it for us and we’ll be happy to continue assisting with the issue.

    Kind regards,
    Pawel

  • xbladerunner
    • Syntax Hero

    Thank you, Pawel —
    I went back and checked the settings and found that the check-box that toggles inclusion of the featured image was not checked — so that was a simple fix. When the next weekly digest was emailed, however, I discovered that the feature images were not appearing as standard sizes, but rather varying per image. All the featured images that appear on the blog are presented in a standard format, but not in the digest email… I don’t recall ever creating a new template, but maybe I did at some point, I’ve been using SBE for years now. Can you help me identify what I need to do to get these images to show up in a standard format (like on the blog) when sent out in our weekly digest? I have opened support access. It is the Cincinnati subsite of the multisite that has SBE activated. Thank you!

  • Nastia
    • Support Rock Star

    Hello xbladerunner

    I trust you’re doing well!

    The Subscribe by Email plugin has currently the following template, that showing featured images on the side. Please see this screenshot:

    Please clarify what do you mean by , showing images in a standard format? Please describe how you wish to show the image. The images in the current template have the same dimensions as shown on a blog page, on your site. Please see this screenshot:

    The Subscribe By Email templates are located in the following directory:
    /wp-content/plugins/subscribe-by-email/inc/mail-templates/views/

    The image dimensions can be located in the post.php file, inside that directory, on line #10. This is the file that needs to be customized to change the image appearance.

    <div <?php echo sbe_show_featured_image() ? 'style="float:left;width: 394px;"' : ''; ?>>
    

    Depends on the chnages you wish to make on an emage, edit the CSS styles in style=”float:left;width: 394px;, for example you may chnage the width to 100% and add height:auto;.

    To make sure the template will not be lost after the plugin/theme update, please copy the edited files , and place them to the child theme of your site.
    wp-content/themes/urc-chapter-child/subscribe-by-email

    Please let us know if you have any further questions!

    Kind regards,
    Nastia

  • xbladerunner
    • Syntax Hero

    Thanks Nastia,

    What I meant by “standard format” is the rectangle image shown in the template image — that is, I want the images (featured images) in the newsletter to be all the same dimensions, but they aren’t, they are the same width, but not all the same height… Not sure how that came to be, as I said, they all use to be displayed in the same rectangle format but now they have reverted to the same relative dimensions of whatever the original photo is. Does that make sense?

  • Pawel
    • Staff

    Hello xbladerunner !

    All clear now! In that case, what Nastia said above should fix the issue for you.

    Additionally, if you want to avoid getting resizing artifacts (ie. when the image has different aspect ratio than what you want it to have in the newsletter), you may be interested in adding object-fit CSS property to the code so that the image will be resized properly. I suggest using “contain” in this case. Here’s some additional docs on that: https://css-tricks.com/almanac/properties/o/object-fit/

    I’ve also asked the developer of SBE to take a look at this ticket to possibly find out what may have caused this change.

    Kind regards,
    Pawel

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.