[Hummingbird Pro] Problem hummingbirg - Minification - Break site

Hello,
I contact you as I have a problem with hummingbird.
I don't understand the way it minifies the html, js scripts and css, as when I check the source the HTML is not minified at all, cannot combine the css and js...
But my main problem is my theme style is broken when minify.
Any way to be able to disable the minification? or control it?
In the advanced tools asset optimization even I don't change anything I have a problem with the style of the theme when minified and the report shows my page are minified!

Also taking into account my server is under ngnix and http/2 protocol can I combine hummingbird with another plugin to be able to combine and minify correctly? if yes which plugin you recommend?

Thx

  • Pawel
    • Staff

    Hello Thibaut!

    I hope you're well today and thank you for reaching out to us!

    Sorry to hear about the issue you are facing. That can sometimes happen, as minification is quite difficult task to carry - taking into account the number of possible plugin and theme combinations. We even warn users with a popup when you activate Asset Optimisation that this feature can break sites. We can help in certain cases and are happy to do so.

    Important note: the HTML isn't minified, only JS and CSS.

    I'd like to take a look and maybe find a solution to the issue you are facing. Sometimes it's caused by non-standard practices in plugins and themes and there is a solution usually. For this, please enable Support Access.

    To enable support access you can follow this guide here:
    https://premium.wpmudev.org/docs/getting-started/getting-support/#chapter-5

    Please respond in this ticket once access is granted.

    Cheers,
    Pawel

  • Thibaut
    • New Recruit

    Hello,
    actually, I granted support access before but it seems you didn't see.
    I just granted again if you can check.

    following my ticket, you can see that when hummingbird is activated it doesn't display correctly the first-page header...
    https://new.companyvauban.com/?avoid-minify=true <--- this is correct
    https://new.companyvauban.com/ <--- this makes the problem

    I tried to deactivate asset optimization but it still has a problem
    Thx

  • Dimitris
    • Support Star

    Hello there Thibaut,

    hope you're doing well today! :slight_smile:

    I went ahead and noticed that initially, I wasn't even able to deactivate Asset Optimization as when I was trying to do so I wasn't getting back to the assets list. This made me think that some kind of caching was doing that so I flushed the Redis Cache from
    https://yourdomain.com/wp-admin/options-general.php?page=redis-cache
    and the minified page (even though you hadn't selected any file to be minified actually), looks good:

    Please do let us know if you're still encounter issues with that!
    Thank you,
    Dimitris

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.