[Hummingbird Pro] Update from v1.x to v2.current, save cache settings led to fatal error

I worked around the issue... but wanted to report this error. i found it very odd... this is an incredibly simple site, with very few plugins activated.

I believe that I realize what caused the issue... so FYI, i was upgrading Hummingbird from pre v2 to current version. seemed to be missing a check on the advanced-cache.php file?

[01-Jun-2019 17:06:03 UTC] PHP Fatal error:  Uncaught Error: Call to a member function write() on null in /wp-content/plugins/wp-hummingbird/core/modules/class-module-page-cache.php:1522
Stack trace:
#0 /wp-content/plugins/wp-hummingbird/core/modules/class-module-page-cache.php(274): WP_Hummingbird_Module_Page_Cache::log_msg('[17:06:03] Load...')
#1 /wp-content/plugins/wp-hummingbird/core/modules/class-module-page-cache.php(908): WP_Hummingbird_Module_Page_Cache::load_config()
#2 /wp-content/plugins/wp-hummingbird/core/modules/class-module-page-cache.php(1326): WP_Hummingbird_Module_Page_Cache::should_cache_request('/explore/wp-log...')
#3 /wp-content/advanced-cache.php(32): WP_Hummingbird_Module_Page_Cache::serve_cache()
#4 /wp-settings.php(95): include('/home/jdubsent/...')
#5 /wp-config.php(107): require_once('/home/ in /wp-content/plugins/wp-hummingbird/core/modules/class-module-page-cache.php on line 1522
  • Nithin
    • Support Wizard

    Hi splaquet,

    I'm afraid, I'm not able to replicate this in my system during plugin update. However, I'm bringing this error noticed into our developer's attention, so that they could give a closer look, and see whether there are any further improvements that could be done in the plugin side regarding this.

    Thank you for bringing this into our attention. Have a nice day.

    Kind Regards,
    Nithin

  • Nithin
    • Support Wizard

    HI splaquet,

    We further tried to replicate this issue further, but I'm afraid we aren't able to replicate this in our side. If you still have a website where the issue still exists, maybe you could set up a staging where we could further test, and see what could be causing this?

    You can send credentials of your staging website by using our secure contact form: https://premium.wpmudev.org/contact/#i-have-a-different-question

    - To Mark to my attention, the subject line should contain only: ATTN: Nithin Ramdas
    -WordPress admin username
    -WordPress admin password
    -login URL
    -FTP credentials (host/username/password)
    -link back to this thread for reference
    -any other relevant URLs

    Please do follow up in the ticket once you have sent the above credentials. Have a nice day. :slight_smile:

    Kind Regards,
    Nithin

  • splaquet
    • The Incredible Code Injector

    it's all good. i was only reporting on what appeared to be an issue. i was comfortable enough with dealing with the advanced-cache file to fix it up.

    it looked like it hadn't added it/removed the file (and/or the cache line in wp-config) upon the update

    no worries! all good over here :slight_smile:

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.