[Hummingbird Pro] slow speed

my website speed was very slow and thats the reason i wanted to use your services to get my website run faster. i have installed hummingbird and smush it. done the settings as recommended. i even hired a professional to do the compression, his job made abit of difference but i did not see any changes by installing your plugins. is there anything im missing in the settings? need help please.

  • Adam Czajczyk
    • Support Gorilla

    Hi abbas

    I hope you’re well today and thank you for your question!

    I checked the site from outside and I noticed a few things there:

    – Google PageSpeed score for desktop is pretty decent actually (80) while for mobile is rather low

    – YSlow Score in GTMetrix is high (90%) but at the same time “fully loaded time” is pretty long

    – there are several critical issues detected by GTMetrix, related mostly to image optimization and there’s also quite a long TTFB (Time To First Byte – so basically waiting time for the first response from the server when browser asks for page to be served)

    – at the same time the actual performance in the browser seems to vary a lot – for me the site was loading sometimes really fast (less than a second) while sometimes was taking much longer.

    So, there are some inconsistencies and I believe that needs to be reviewed. Caching, Asset Optimization and that kind of tools – they are all great and can really speed up the site a lot but if there are some issues “under the hood” (some errors, some conflicts, some “aspects” of the site that e.g. cause too high server resource usage) they would have to be addressed as well.

    That being said, I’d like to take a closer look at this. Would you please enable support access to the site for me? To do so, please go to the “WPMU DEV -> Support -> Support Access” page and click on “Grant support access” button there.

    Before doing that though – could you please:

    – disable RocketLoader in CloudFlare for now

    – and temporarily put CloudFlare on “Pause” (there’s a “pause” option at the bottom of right column of “Overview” tab for the domain in CloudFlare dashboard).

    I’m asking for this because Rocket Loader of CloudFlare might interfere with Asset Optimization sometimes and CloudFlare itself might efficiently “cover up” a lot of things happening between browser and your site that I would normally see in browser console – so it should be enabled back at the very end of any troubleshooting/optimization.

    Looking forward to hear from you,

    Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.