Hummingbird says gzip is not working properly

Hi!
This is a new installation. I am trying to achieved a WPMU hosting to make good use of your plugins :slight_smile: hehehe.
When I try to activate the Gzip compression in Hummingbird, it says,
"gzip is not working properly:
- Your server may not have the "deflate" module enabled (mod_deflate for Apache, ngx_http_gzip_module for NGINX)
- Another plugin may be interfering with the configuration"
My server runs in Linux Centos 7 in Apache 2.4, Mariadb 10.1 and php 7.1 and the deflate module is on. But I am getting this error? And whenever I try to recheck the status, the hummingbird has different output. And seriously, I am rechecking the status when gzip compression is off and it sometimes giving me all green status?
Also, how this hummingbird can support the subdirectory, too? I couldn't find any information on this.
I have granted support access. Thanks!
Regards,
Jo